none
Ctrl-scroll okay for editor. Need same for sidebar explorers

    Question

  • My eyes are not as good as they used to be, and I use reading glasses a lot. So I found myself searching for a zoom function.

    I found I can go to tools, options, environment, fonts and colors to increase the font size.  But that is unnecessary because ctrl-scroll is trivial for increasing/decreasing the font size.  In fact ctrl-scroll is perfect everywhere I have ever needed it EXCEPT in Visual Studio Community 2015.

    The problem is that neither the tools option nor the ctrl-scroll works appears to work for anything but the code editor.  I need the same zoom capability to work in the explorers, especially the Solution Explorer.  See screen shot attached.

    Is there a solution posted elsewhere using search keywords I missed?

    Screen shot showing zoom in for Code Editor, but can't find feature to do same for Solution Explorer.

     

    Friday, February 05, 2016 12:24 AM

Answers

  • Hi wkrasl,

    Thanks for your post.

    1. Go to  Tools->Options->Environment->Fonts and Colors

    2. In "Show Settings for" chose "Environment Font" 

    3. In "Font" replace Automatic to  for example,  Arial and change size.

    Change the font size of that setting, all Font size in the Explorers (Solution Explorer, Server Explorer and Toolbox) and menus will change.

    You can also refer to this thread:

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/7fd12e24-280a-455f-8d9f-458708478e42/set-solution-explorer-fontsize-in-vs2012?forum=vssetup

    Best Regards,

    Lake Xiao

    Friday, February 05, 2016 7:00 AM
    Moderator
  • Hi wkrasl,

    Can you increase the font size with the steps in my previous reply.

    If your problem was solved.  Please mark the reply as the answer which is helpful, so it would be helpful for other members who get the same issue as yours to research and find the answer directly, and I could close this case.

    Have a nice day.

    Best Regards,

    Lake Xiao

    • Marked as answer by wkrasl Monday, February 15, 2016 1:16 PM
    Monday, February 15, 2016 9:28 AM
    Moderator

All replies

  • Hi wkrasl,

    Thanks for your post.

    1. Go to  Tools->Options->Environment->Fonts and Colors

    2. In "Show Settings for" chose "Environment Font" 

    3. In "Font" replace Automatic to  for example,  Arial and change size.

    Change the font size of that setting, all Font size in the Explorers (Solution Explorer, Server Explorer and Toolbox) and menus will change.

    You can also refer to this thread:

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/7fd12e24-280a-455f-8d9f-458708478e42/set-solution-explorer-fontsize-in-vs2012?forum=vssetup

    Best Regards,

    Lake Xiao

    Friday, February 05, 2016 7:00 AM
    Moderator
  • Hi wkrasl,

    Can you increase the font size with the steps in my previous reply.

    If your problem was solved.  Please mark the reply as the answer which is helpful, so it would be helpful for other members who get the same issue as yours to research and find the answer directly, and I could close this case.

    Have a nice day.

    Best Regards,

    Lake Xiao

    • Marked as answer by wkrasl Monday, February 15, 2016 1:16 PM
    Monday, February 15, 2016 9:28 AM
    Moderator
  • Thanks for reminding me to take another look at this. 

    As you might have guessed, I had overlooked the ability to switch Show Settings For."  Once I selected "Environment Font" and selected Arial font, I was able to increase the size from 9 to 11.  It is perfect for my aging eyes.  LOL

    Kudos!

    Monday, February 15, 2016 1:16 PM