locked
HealthVault Hello World sample: Server Error:The resource cannot be found RRS feed

  • Question

  • I am a student hoping to write a HealthVault app as part of my final year project but I'm having trouble running any of the samples.

    I am using the UK HealthVault-ppe and have changed the appSettings to:

    <add key="ShellUrl" value="https://account.healthvault-ppe.co.uk/" />
    <add key="HealthServiceUrl" value="https://platform.healthvault-ppe.co.uk/platform/" />
    

    When I run the application it goes to the HealthVault-ppe site and shows the logo that I added for the application. However, after signing in and being redirected back I get the following server error:

    Server Error in '/' Application.
    The resource cannot be found.
    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.
    
    Requested URL: /Redirect.aspx
    
    Version Information: Microsoft .NET Framework Version:2.0.50727.4952; ASP.NET Version:2.0.50727.4955

    Do you have any clues as to what is going wrong here?

    Thanks

    Elizabeth

    Tuesday, October 5, 2010 2:41 PM

Answers

  • Hello Elizabeth,

    You will not be able to change any configuration of sample application's which comes along with HealthVault SDK , So you need to create your own Application ID to work with UK environment from config center.

    You can only create a new ApplicationId from the configuration center(https://config.healthvault-ppe.co.uk ) not from the HealthVault Application manager for UK environment. Please look for the create a new application link within the Application Configuration Center.
    Please check the following blog, Creating the Key Pair section for creating your own ApplicationId and certificates: http://msdn.microsoft.com/en-us/healthvault/bb814945.aspx

     

    Regards,

    Madan Kamuju

    • Proposed as answer by Madan kamuju Friday, October 8, 2010 11:30 AM
    • Marked as answer by Aneesh D Wednesday, November 24, 2010 9:29 PM
    Thursday, October 7, 2010 10:05 AM
  • Hello Elizabeth,

    For resolving the above issue you need to follow these steps from this block "Exporting Your Private Key and Installing It on Your Application Server" in this url http://msdn.microsoft.com/en-us/healthvault/bb814945.aspx after creating application and then run the application.

                                      Or

    You can also create application id from HealthVault application Manager by modify DropOffUrl of ApplicationManager.exe.config file available in this path C:\Program Files\Microsoft HealthVault\SDK\Tools\ApplicationManager.exe.config.

    Existing tag

    <appSettings>
        <add key="DropOffUrl" value="http://config.healthvault-ppe.com/RegisterNewApplicationDropoff.aspx" />
        <add key="TurnOnUpload" value="true" />
      </appSettings> 

    Changed it like below and save the file.

    <appSettings>
        <add key="DropOffUrl" value="http://config.healthvault-ppe.co.uk/RegisterNewApplicationDropoff.aspx" />
        <add key="TurnOnUpload" value="true" />
      </appSettings> 

    Then open the HealthVault Application manager run as administrator.

    Click on Click on Create New Application give the application name 

    Uncheck Automatically Create VisualStudioWebsit then Create and Register Application.

    Copy the application Id from HealthVault Application manager by right click on application and copy to clipboard and Past the application Id in your web.config file and run the application.

     

    Hope this helps and let me know if you face any issues.

    Regards,

    Madan Kamuju

     

     

    • Proposed as answer by Madan kamuju Thursday, October 14, 2010 9:25 AM
    • Marked as answer by Aneesh D Wednesday, November 24, 2010 9:28 PM
    Wednesday, October 13, 2010 12:20 PM

All replies

  • Hello Elizabeth,

    I am able to reproduce the issue and i am following up with our Product Group. I will update you soon once i get some information.

    Regards,

    Madan Kamuju

     

    Tuesday, October 5, 2010 5:24 PM
  • Hello Elizabeth,

    This issue is resolved now. Could you please verify from your side and let me know if you face any issues.

    Thanks for your patience.

     

    Regards,

    Madan Kamuju

    Wednesday, October 6, 2010 3:34 PM
  • Hi Madan

    The Hello World sample now works. Thank you.

    As well as the HealthVault Application Manager, I have been using the UK Application Configuration Centre to try to register both the Hello World and Weigh Tracker samples. I have added the relevant public certificate and then in the web.config file amended the ApplicationId element. When I run the application, it goes to the correct startup page (showing my logo) but when it returns I get an error saying the certificate cannot be found (which is correct because I have changed the ApplicationId). How do I create the appropriate certificate using the UK Application ID? Or am I doing this wrong?

    I have been following the tutorials and help guides but there isn't much information about using the UK version.

    Regards

    Elizabeth

    Wednesday, October 6, 2010 8:09 PM
  • Hello Elizabeth,

    You will not be able to change any configuration of sample application's which comes along with HealthVault SDK , So you need to create your own Application ID to work with UK environment from config center.

    You can only create a new ApplicationId from the configuration center(https://config.healthvault-ppe.co.uk ) not from the HealthVault Application manager for UK environment. Please look for the create a new application link within the Application Configuration Center.
    Please check the following blog, Creating the Key Pair section for creating your own ApplicationId and certificates: http://msdn.microsoft.com/en-us/healthvault/bb814945.aspx

     

    Regards,

    Madan Kamuju

    • Proposed as answer by Madan kamuju Friday, October 8, 2010 11:30 AM
    • Marked as answer by Aneesh D Wednesday, November 24, 2010 9:29 PM
    Thursday, October 7, 2010 10:05 AM
  • Hi Madan

     

    I have registered my application with the UK Configuration centre and generated a key pair following the instructions. I then emailed the public certificate to ukgolive@microsoft.com.

    Is this the correct procedure or is there another email address I should be using for these requests?

     

    Regards

    Elizabeth

     

     

    Monday, October 11, 2010 6:39 PM
  • Hello Elizabeth,

    You don't need to send the .cer file to go-live process(golive email) because you are developing only a sample application. When ever you would like your application to be live then only you need to go through go-live process.

    To create the private/public key pair in your machine:

    1. Open site : https://config.healthvault-ppe.co.uk/CreateNewApp.aspx
    2. Copy Application id from Application id textbox and use the same application id in below step 4 makecert.exe command.


    3. Find makecert.exe in C:\Program Files\Microsoft Visual Studio 8\Common7\Tools\Bin. It is also available in the Downloads section of the HealthVault MSDN site.

    4. Using the MakeCert command, generate a certificate with the same name as the one that we sent you when your AppId was created:

    makecert.exe "<OutputPath>\<CertFileName>.cer" -a sha1 -n "CN=WildcatApp-<paste AppId>" -sr LocalMachine -ss My -sky signature -pe -len 2048

    For example:

    makecert.exe "c:\temp\MyCert.cer" -a sha1 -n "CN=WildcatApp-a1b3219c-766b-41de-bc85-854dc2bd0ce8" -sr LocalMachine -ss My -sky signature -pe -len 2048

    5. Once you get the .cer file just browse in Public certificate (Public certificate is not required for applications of type Soda) in the config site at createNewapp.aspx.

    6. check the check box.


    7. Create application.

    Use the above created Application Id in your web.config file and run your application.

    Hope this helps and let me know if you face any issues.

    Regards,

    Madan Kamuju

    • Edited by Madan kamuju Wednesday, October 13, 2010 12:21 PM
    • Proposed as answer by Madan kamuju Thursday, October 14, 2010 9:25 AM
    Tuesday, October 12, 2010 8:56 AM
  • Hi Madan

    I had followed these instructions but when I run the application I get this exception:

    "The specified certificate, CN=WildcatApp-0579087c-5733-431d-b772-df92cf0704f6, could not be found in the LocalMachine certificate store,or the certificate does not have a private key."
    

    The certificate is in the local certificate store but it doesn't appear to have a private certificate (when I right click and go All Tasks, Manage Private Keys is not an option, like the other keys in the store). Does the private certificate have to be created separately using makecert.exe? Or is it not being created correctly?

    I'm using Windows 7 with Visual Studio 2008.

    Regards

    Elizabeth

    Tuesday, October 12, 2010 8:32 PM
  • Hello Elizabeth,

    For resolving the above issue you need to follow these steps from this block "Exporting Your Private Key and Installing It on Your Application Server" in this url http://msdn.microsoft.com/en-us/healthvault/bb814945.aspx after creating application and then run the application.

                                      Or

    You can also create application id from HealthVault application Manager by modify DropOffUrl of ApplicationManager.exe.config file available in this path C:\Program Files\Microsoft HealthVault\SDK\Tools\ApplicationManager.exe.config.

    Existing tag

    <appSettings>
        <add key="DropOffUrl" value="http://config.healthvault-ppe.com/RegisterNewApplicationDropoff.aspx" />
        <add key="TurnOnUpload" value="true" />
      </appSettings> 

    Changed it like below and save the file.

    <appSettings>
        <add key="DropOffUrl" value="http://config.healthvault-ppe.co.uk/RegisterNewApplicationDropoff.aspx" />
        <add key="TurnOnUpload" value="true" />
      </appSettings> 

    Then open the HealthVault Application manager run as administrator.

    Click on Click on Create New Application give the application name 

    Uncheck Automatically Create VisualStudioWebsit then Create and Register Application.

    Copy the application Id from HealthVault Application manager by right click on application and copy to clipboard and Past the application Id in your web.config file and run the application.

     

    Hope this helps and let me know if you face any issues.

    Regards,

    Madan Kamuju

     

     

    • Proposed as answer by Madan kamuju Thursday, October 14, 2010 9:25 AM
    • Marked as answer by Aneesh D Wednesday, November 24, 2010 9:28 PM
    Wednesday, October 13, 2010 12:20 PM
  • Hi Madan

     

    I modified the ApplicationManager.exe.config file as you suggested and my application now works.

    Thank you for your help with this.

     

    Regards

    Elizabeth

    Wednesday, October 13, 2010 8:43 PM