none
Minimum VSTO runtime version targeting the .NET 4.5.2 Framework RRS feed

  • Question

  • Hi,

    I am developing an Outlook Add-in using c# on .NET 4.5.2. I wanted to know what is the minimum version of the VSTO runtime that is needed, which will work on .NET 4.5.2.

    I know there are many versions under VSTO 4.0, but i need the exact minimum version like 10.0.40820 or 10.0.60724 etc. Is there any page or wiki where I can have a look at all the VSTO runtimes released till date? That would be great.

    Regards, Kiran

    Wednesday, December 2, 2015 6:23 AM

All replies

  • Hello Kiran,

    Why do you need the exact minimum version?

    The fact is that VSTO is a part of Visual Studio (included in the paid editions plus Community). So, the installed VSTO version supports .Net versions available in Visual Studio. If VS supports .net framework 4.5.2 then VSTO will too. You may find the Running Solutions in Different Versions of Microsoft Office article helpful.

    Wednesday, December 2, 2015 10:38 AM
  • Hi Eugene,

    I am talking from the perspective of end user. The VSTO that is bundled with Office 2010, targets only the .NET 3.5 and below, whereas the one that is bundled with Office 2013 targets .NET 4.5.2 as well. I am developing an Outlook Add-in that needs to be run on the end user's machine which have Office 2010 installed. For that, the users have to explicitly install VSTO runtime. I searched a lot in the MSDN, but I don't find anything related to VSTO releases. Hope you got my point :)

    Regards, Kiran

    Thursday, December 3, 2015 3:14 AM
  • Hi Kiran,

    Office 2010 applications include the Visual Studio 2010 tools for Office Runtime, so the users don’t need to explicitly install VSTO runtime. More information: https://msdn.microsoft.com/en-us/library/bb608603(v=vs.100).aspx

    Do you mean your add-in doesn't work in the customer machine? Are there error message in the event viewer?

    Regards

    Starain


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Friday, December 4, 2015 8:48 AM
    Moderator
  • Hi,

    Does your issue been solved?

    Regards

    Starain


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, December 15, 2015 9:28 AM
    Moderator