none
Integrating BizTalk with JDE EnterpriseOne RRS feed

  • Question

  • HI Guys,

    I am using BizTalk Server 2013R2 Enterprise One Adapter for integrating JDE 9.1 (Tool release 9.1.3.1) with Oracle database.

    I have also created solicit response send port in BT Admin console and also provided JDEEnterprise Transport properties along with credentials to login to JDE server.

    Also provided all the essential JAR files. I am using Java jdk1.7.0_71 version.

    But when I try to Generate Schema using Add Adapter wizard, I get following error:

    "The adapter did not return any service description files."

    When traced event viewer I got following error.

    I-JDE0042: Login failed: com.jdedwards.system.connector.dynamic.ServerFailureException: Cannot connect to any OneWorld Security Server.FAILURE: null

    E-JDE0027: Unable to acquire J.D.Edwards connection object.   Please check the settings of the port.

    One thing I noticed:

    When I put wrong credentials in the send port adapter properties to connect to JDE system still I get same exception.

    Can someone guide me on the correct path...

    Thanks in advance

    /Dhiraj Bhavsar

    Tuesday, November 4, 2014 10:23 AM

Answers

  • I had set up call with the Microsoft Support team and they say that the BizTalk 2013R2 (JDE LOB Adapter) is not tested against latest release of JDE EnterpriseOne 9.1.

    It only supports with 8.12 and 9.0 version of JDE.

    Now we are going with the BSSV (Webservice call) to connect to JDE.

    Thanks/Dhiraj Bhavar

    • Marked as answer by Dhiraj Bhavsar Saturday, November 15, 2014 11:42 AM
    Saturday, November 15, 2014 11:42 AM

All replies

  • Hi GUys,

    Have anyone successfully connected using latest release of BizTalk (2013R2) and JDE 9.1?

    Thanks/Dhiraj Bhavsar

    Wednesday, November 12, 2014 9:21 AM
  • Hi Dhiraj,

    It was long while I had worked with JDE ,What i remember is you need to do some class declaration.

    I would suggest to look the issue in JDE forum as its because of some missing setting on your windows server related to .jar and sdk files.

    Microsoft Error list link

    Thanks

    Abhishek

    Friday, November 14, 2014 3:51 PM
  • I had set up call with the Microsoft Support team and they say that the BizTalk 2013R2 (JDE LOB Adapter) is not tested against latest release of JDE EnterpriseOne 9.1.

    It only supports with 8.12 and 9.0 version of JDE.

    Now we are going with the BSSV (Webservice call) to connect to JDE.

    Thanks/Dhiraj Bhavar

    • Marked as answer by Dhiraj Bhavsar Saturday, November 15, 2014 11:42 AM
    Saturday, November 15, 2014 11:42 AM