locked
The remote procedure call failed. [0x800706be] RRS feed

  • Question

  • I have just installed "SQL Server 2008 R2 Express with Advanced Services" on my Windows 7 workstation.  I'm going through the Walkthrough: Installing and Configuring SQL Server 2008 R2 Express with Advanced Services located here: http://msdn.microsoft.com/en-us/library/gg512108(v=vs.91).aspx.  I'm down to the heading "Configure Your New Instance of SQL Server for the Installation of the AdventureWorks Databases" step 2 which says: in SQL Server Configuration Manager left pane select "SQL Server Services.  When I do,  I get this:

    Can anyone help me solve this problem?


    Joe

    Tuesday, March 13, 2012 2:54 AM

Answers

All replies

  • Possibly the SQL Server Configuration Manager in the screen shot is for a non-SQL Server 2008 R2 version and therefore it cannot enumerate the SQL Server 2008 R2 services.

    If you have another version of SQL Server on your workstation, see if you have another SQL Server Configuration Manager and try that (it should be under SQL Server 2008 R2 -> Configuration Tools on your start menu).

    Tuesday, March 13, 2012 3:14 AM
  • Hi Kevin,

    Thank you for your suggestion, but unfortunately that isn't the case.  I am using the SQL Server Configuration Manager that's under SQL Server 2008 R2.  Here's information from Application Event Viewer in case that helps:

    Faulting application name: wmiprvse.exe, version: 6.1.7601.17514, time stamp: 0x4ce79267
    Faulting module name: svrenumapi100.dll, version: 2009.100.1600.1, time stamp: 0x4bb682e9
    Exception code: 0xc0000005
    Fault offset: 0x0003a0bf
    Faulting process id: 0x1474
    Faulting application start time: 0x01cd0116ce3fef99
    Faulting application path: C:\Windows\sysWOW64\wbem\wmiprvse.exe
    Faulting module path: c:\Program Files (x86)\Microsoft SQL Server\100\Shared\svrenumapi100.dll
    Report Id: 0c87e3c3-6d0a-11e1-a5dc-5cac4ce6b1eb

    The second from last line, "Faulting module path:", is curious to me since I installed SQL Server 64-bit.  My Windows 7 is 64-bit.

    Any further suggestions are welcome.

    Thanks again,

    Joe


    Joe

    Tuesday, March 13, 2012 1:02 PM
  • I have completely uninstalled SQL Server (all instances) and then re-installed SQL Server Express 2008 R2.  The installation went smoothly and completed successfully.

    But I'm still getting the same error.  Before the error appears, there's a message: "Requesting data from WMI provider..."

    I need to get this solved.  Anyone have a clue?


    Joe

    Tuesday, March 13, 2012 7:43 PM
  • This process appears to depend on one of the WMI providers included in SQL Server 2008 R2 that don't appear to be working.  According to this blog post about WMI and SQL05, the .mof files that WMI uses might not register correctly.  If you look in C:\Program Files\Microsoft SQL Server\10.5\Shared\ for an .mof file and run mofcomp on that file, it might get it to work.  From the message you posted, it looks like that was the root cause of your original issue.
    Tuesday, March 13, 2012 7:57 PM
  • It may be worth trying the System Update Readiness Tool http://support.microsoft.com/kb/947821 to see if it detects any issues on your system.

    If that fails, possibly try apply the latest SQL Server 2008 R2 service pack http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=26727 or if you have that, the latest QFE http://support.microsoft.com/kb/2659694

    • Marked as answer by Joe G Thursday, March 15, 2012 3:37 PM
    Tuesday, March 13, 2012 8:45 PM
  • I executed the mofcomp.exe on the following file:

     Directory of C:\Program Files (x86)\Microsoft SQL Server\100\Shared

    04/02/2010  04:12 PM            24,848 sqlmgmproviderxpsp2up.mof
                   1 File(s)         24,848 bytes
                   0 Dir(s)  83,656,482,816 bytes free

    C:\Program Files (x86)\Microsoft SQL Server\100\Shared>

    I thought sure that would solve my problem, but unfortunately it didn't.  The file above is the only one under C:\Program Files (x86)\Microsoft SQL Server\

    There are 13 *.mof files under C:\Program Files\Microsoft SQL Server\ shown below.  I'm thinking about executing mofcomp.exe on each of those.  Do you think that might make matters worse?  By the way, I see you have a subfolder named "10.5" which I don't have. I have 80, 90, 100, and 110. Don't know if that's significant or not.


    Joe

    Wednesday, March 14, 2012 12:54 AM
  • I don't think it would hurt to try on all of the MSSQL* files.  The LocalDB ones should just be for SQL 2012 LocalDB, which (I suppose) shouldn't interfere with the main server.  If you are worried, you could create a restore point and then rollback if something else goes wrong.
    Wednesday, March 14, 2012 1:15 PM
  • Hi Kevin,

    Things are looking up.  I installed Service Pack 1 as you suggested and that solved my problem!

    Hurrah!  Thank you very much and thanks to others who contributed suggestions.

    Joe


    Joe

    • Proposed as answer by MarvinPerkins Friday, February 8, 2013 6:03 PM
    Thursday, March 15, 2012 3:52 PM
  • Thanks, SQL Server 2008R2 service pack 1 resolved this issue. http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=26727
    • Proposed as answer by MarvinPerkins Friday, February 8, 2013 6:05 PM
    Saturday, April 7, 2012 7:20 PM
  • I had the exact same problem.  Resolved by installing SP1, thanks! 


    mp

    Friday, February 8, 2013 6:04 PM
  • This also worked for me. Thanks for the help.
    Tuesday, September 17, 2013 4:12 AM
  • [Error Message]

    if i try to install  SQL Server 2008R2 service pack 1 iam getting following error in instaallation process

    There are no SQL Server instances or shared features that can be updated on this computer.

    Wednesday, September 10, 2014 5:15 AM
  • This Worked For Me

    Open Control Panel > Administrative Tools > Services > Select Standard services tab (under the bottom) > Find start SQL Server Agent

    Right Click and select properties,

    Startup Type : Automatic,

    Apply, Ok.

    Done.

    Saturday, December 20, 2014 9:25 AM