locked
ShareOperation.reportCompleted() exception

    Question

  • When I call the reportCompleted() method I am getting this exception.

    0x80070491 - JavaScript runtime error: There was no match for the specified key in the index.

    I am even seeing this in the sample app.  Does anyone know what I am missing?

    Wednesday, March 28, 2012 12:21 PM

Answers

All replies

  • Which sample are you refering to?


    Jeff Sanders (MSFT)

    Wednesday, March 28, 2012 1:34 PM
    Moderator
  • I'm sorry it wasn't in the sample app but when I add a Share Contract to my project it adds code that is suppose to work.  In there it throws an exception on reportCompleted();

    Wednesday, March 28, 2012 1:54 PM
  • Sorry, now idea what you could be missing, can you compare your code to one of the sharing samples and if you do not see where it is different can you post a simple repro here?


    Jeff Sanders (MSFT)

    Wednesday, March 28, 2012 2:52 PM
    Moderator
  • I took a look at the sample, "Sharing content target app sample".   I ran the app then went into IE > opened up the charms and selected Share.  From there I chose Share Target Sample App.

    When I clicked on the Report Completed button it fires the reportCompleted click handler. In that function shareOperation.reportCompleted() is called.

    I am getting the same exception here too.  I didn't modify the sample app at all.  

    Is there another target sharing sample app where this is working?

    Wednesday, March 28, 2012 3:11 PM
  • Thanks Duke,  (Duke the school or Duke-nukem?).

    I was able to repro the issue.  I will update this post later with what I find.

    -Jeff


    Jeff Sanders (MSFT)

    Wednesday, March 28, 2012 7:42 PM
    Moderator
  • Jeff,  Wondering if you came up with anything?
    Monday, April 2, 2012 5:55 PM
  • Not yet, the developers are still actively looking into this though.


    Jeff Sanders (MSFT)

    Monday, April 2, 2012 8:54 PM
    Moderator
  • I ran into the same issue today with my share target app. Interesting it was working last week when I was testing it and I haven't changed anything in my code since then. Was there a specific reason for this error?
    Monday, August 13, 2012 4:25 PM
  • Look for this to be fixed in the next version!

    Jeff Sanders (MSFT)

    Monday, August 13, 2012 5:57 PM
    Moderator