locked
Regarding Visual Studio 2015 Community Edition RRS feed

  • Question

  • User-1664020322 posted

    Hi,

    I would like to know if I'm the only on who is facing the following issue with visual studio 2015 community edition.

    I was recently working on Master Pages project using visual studio. So, Sometimes when I try to write asp:textbox or any asp tags, the child pages doesn't recognize asp tags. It always gives me the warning as asp tags are not found. for this file. So, I restarted the visual studio and After that the same page recognizes the asp tags. 

    I don't know if this is visual studio issue or if there is something I can do to get rid of the problem.

    I'm not sure if this is the right place to ask for this problem. 

    Wednesday, October 12, 2016 9:05 PM

Answers

  • User347430248 posted

    Hi Sandeep,

    Are you trying to copy paste the code from somewhere?

    First suggestion is to clean your project and rebuild again. solves the issue.

    Second suggestion go to the web.config file.

    try to find the code like mentioned below and remove it.

    <pages>
      <controls>
        <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
      </controls>
    </pages>

    Regards

    Deepak

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, October 13, 2016 2:25 AM

All replies

  • User347430248 posted

    Hi Sandeep,

    Are you trying to copy paste the code from somewhere?

    First suggestion is to clean your project and rebuild again. solves the issue.

    Second suggestion go to the web.config file.

    try to find the code like mentioned below and remove it.

    <pages>
      <controls>
        <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
      </controls>
    </pages>

    Regards

    Deepak

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, October 13, 2016 2:25 AM
  • User-1664020322 posted

    Hi Deepak,

    No, Actually I'm developing my own design using Bootstrap. The thing is all of a sudden visual studio freezes and starts giving me this warning. 

    But to keep you posted, your first idea worked for me. I cleaned and re-build the solution and waited for a while for visual studio to settle down and started writing my design. And, now visual studio works fine for me.

    Thank You very much for taking time.

    Best Regards,

    Sandeep

    Thursday, October 13, 2016 6:34 PM