locked
error during local report processing RRS feed

  • Question

  • User-431851830 posted
    • Hi all,

      I have created a simple Local report(rdlc) from VS2010, added this rdlc to report viewer.

      I am getting this following error.

      An error occurred during local report processing. The report definition for report 'WebUI.Report.Report1.rdlc' has not been specified

      For the past 3 days I have  tried all the work around for the web, but no luck. Need some help ASAP.

      Thanks.

      Rob

    Monday, October 17, 2011 5:06 PM

All replies

  • User-1528094326 posted

    If you added the report to the ReportViewer control using Visual Studio and you are NOT doing it programatically then chances are it means there is something wrong with your report file.

    That error generally indicates it cannot find the ReportFile object for the local report, or there is an error and it cannot render the report.

    Give more information on the report, are you pulling stuff with datasets? Are you doing all this dynamically in the code behind?

    Monday, October 17, 2011 5:19 PM
  • User-431851830 posted

     Yes I’m using a dataset, and i previewed the dataset, it works good.<o:p></o:p>

    This rdlc is a simple report, how do i test the rdlc without binding with report viewer.<o:p></o:p>

    Monday, October 17, 2011 5:37 PM
  • User-1528094326 posted

    well put a reportviewer on the screen and then just try setting the report file programmatically like this:

    // assumes your ReportViewer on the page is called ReportViewer1
    
    ReportViewer1.ProcessingMode = ProcessingMode.Local;
    
    // the ReportPath is relative to the page displaying the ReportViewer
    ReportViewer1.LocalReport.ReportPath = "YourReportFileHere.rdlc";
    
    object YourDataHereForTheReport;
    ReportDataSource rds = new ReportDataSource("YourDataSetNameHere", YourDataHereForTheReport);
    
    ReportViewer1.LocalReport.DataSources.Add(rds);
    
    ReportViewer1.Refresh();
    Monday, October 17, 2011 5:55 PM
  • User-1528094326 posted

    Once you try that out, see where the error comes from or if its a different error, its very possible that its blowing up because of something in the report itself, such as incorrect syntax somewhere in the VBA code.

    Monday, October 17, 2011 5:58 PM
  • User-431851830 posted

    Now I am getting the following error,

    • An error occurred during local report processing.
      • The definition of the report 'Main Report' is invalid.
        • The report definition is not valid. Details: The report definition has an invalid target namespace 'http://schemas.microsoft.com/sqlserver/reporting/2008/01/reportdefinition' which cannot be upgraded.
    Monday, October 17, 2011 6:02 PM
  • User-1528094326 posted

    Are you using ReportViewer 2008 or 2010?

    Monday, October 17, 2011 6:03 PM
  • User-431851830 posted

    ReportViewer.WebForms ,Version=8.0.0.0

    Monday, October 17, 2011 6:08 PM
  • User-1528094326 posted

    ReportViewer 2008 is actually targeted at SQL Server 2005so it won't recognize schema 2008. Try upgrading to ReportViewer 2010 and see if that fixes it. You can download it here:

    http://www.microsoft.com/download/en/details.aspx?id=6442

    after you download and install it, remove the Microsoft.Reporting from your project and then re add them selecting the version 10.0.0.0 

     

    Monday, October 17, 2011 6:12 PM
  • User-431851830 posted

    Hi Scott,

    I have tried to upgrade to 10, I get rid of other error, but i'm getting another one

    • An error has occurred during report processing.
      • Exception has been thrown by the target of an invocation.
        • Procedure uspGetProvider has no parameters and arguments were supplied.
        •      
        • This procedure don't required any parameter. Any help appreciated.
        • Thanks
    Tuesday, October 18, 2011 1:25 PM
  • User-1528094326 posted

    Are you calling a stored procedure? It looks more like you have a stored procedure called uspGetProvider that is throwing an error. So this would be on your backend with the database, the report and reportviewer are not having any errors themselves.

    Tuesday, October 18, 2011 1:29 PM
  • User-431851830 posted

    Oops i figure it out, I just redid the whole thinks and it starts working.

    Thanks you so much for your prompt help.

     

    Tuesday, October 18, 2011 1:40 PM
  • User-431851830 posted

    Hi Scott,

    After adding a parameter to the report(rdlc), report viewer not showing the report.

    Any help appreciated.

    Rob

    Wednesday, October 19, 2011 4:53 PM
  • User-1528094326 posted

    First make sure the report paramater will accept null values if you are not passing anything into it, otherwise you will need to provide a parameter value for it.

    Wednesday, October 19, 2011 5:11 PM
  • User822948328 posted

    you must add all parameter values. use ReportViewer1.LocalReport.SetParameters() in single parameter , or use muliple parameters

    use the ReportViewer1.LocalReport.SetParameters(  < parameter list> )

    Thursday, October 20, 2011 2:53 AM
  • User-431851830 posted

    Steve,

    Can we export the report in CSV format. I can export PDF and excel , exporting CSV gives the following error.

    Error: Specified argument was out of the range of valid values.

    Parameter name: format

    in

    renderedBytes = localReport.Render(reportType,deviceInfo,out mimeType,out encoding,out fileNameExtension,out streams,out warnings);


    Any help appreciated

    Rob

     

    Thursday, October 20, 2011 5:37 PM
  • User-1528094326 posted

    The reportviewer does not support CSV files, only PDF, XLS, and DOC.

    Thursday, October 20, 2011 5:40 PM
  • User-431851830 posted

    I am not using report viewer now, can i export rdlc from the code behind.

    Thursday, October 20, 2011 5:44 PM
  • User-1528094326 posted

    Yes you are. You are using the ReportViewer.LocalReport.Render() method to render the RDLC file. The Render() method only allows XLS and and PDF unless you are using version 2010 which also supports DOC.

    The ReportViewer will not parse through your report and dataset to save items as a CSV (Comma Separated Value) file.

    Thursday, October 20, 2011 5:56 PM
  • User1767255008 posted

    Hi To All,

    I just Solved tnis Issue So if any one had this problem Try this.

    This solution solved lots of issues related to ReportViewer. 

    if (!IsPostBack)
    {
    SqlConnection con = Connection();
    con.Open();
    SqlCommand cmd = new SqlCommand("sp_Get_Company_Details", con);
    cmd.CommandType = CommandType.StoredProcedure;
    using (SqlDataAdapter sda = new SqlDataAdapter())
    {
    cmd.Connection = con;
    sda.SelectCommand = cmd;
    DataSet ds = new DataSet();
    sda.Fill(ds);
    ReportViewer1.ProcessingMode = ProcessingMode.Local;

    ReportViewer1.LocalReport.ReportPath = "Report1.rdlc";
    ReportDataSource rds = new ReportDataSource("DataSet1", ds.Tables[0]);

    ReportViewer1.LocalReport.DataSources.Add(rds);

    //ReportViewer1.LocalReport.Refresh();
    con.Close();
    con.Dispose();
    }
    }

    To deploy on a Server. Please dont forget to install ReportViewer.

    the link is below.

    http://www.microsoft.com/en-us/download/confirmation.aspx?id=29024

    Done.......

    Sunday, June 23, 2013 8:51 AM
  • User1453581161 posted

    Wow awesome, thank you so much this actually fixed it for me.

    Been trying various configurations in IIS for the whole day :)

    Wednesday, June 26, 2013 11:52 AM