none
Error when trying to add a custom web part RRS feed

  • Question

  • Hi,

    I have created a custom web part in VS 2013 on SharePoint 2013. The solution was deployed as a farm solution. There is just basic code to write out to a label. When I try to add the web part to a page, I receive the following error:

    "Unable to load assembly group. The user assemly group provider threw an exception while trying to provide user assemblies for the specified assembly group."

    Any ideas on what I need to do to fix this issue?

    thanks,


    Sherazad

    Wednesday, May 28, 2014 3:22 PM

All replies

  • Are you sure you are using farm solution. According to the following post this type of error occures in sandbox solution

    http://sharepoint-tutorial.net/post/2011/05/31/sandboxed-solution-unable-to-load-assembly-group-the-user-assembly-group-provider-threw-an-exception.aspx

    http://sharepoint.stackexchange.com/questions/11233/i-get-this-error-unable-to-load-assembly-group-when-deploying-the-following-br
    • Edited by Aanchal22 Wednesday, May 28, 2014 3:28 PM
    Wednesday, May 28, 2014 3:26 PM
  • According to the link, you need to check the mannaged account permission which is running the sandbox code service and restart the service.

    Check out this link

    http://social.technet.microsoft.com/Forums/en-US/sharepoint2010programming/thread/f37b58ca-fcea-439e-ab0a-44afca190a5d

    Wednesday, May 28, 2014 3:32 PM
  • Could you share your code.
    Wednesday, May 28, 2014 3:36 PM
  • Hi All,

    Thanks for you responses. This is not a sandbox solution. It is a farm solution.  The code is bascially outputting text on a label. In any case, I did restart the sandbox service and did an IIS reset. Still the same issue with the VS2013 webpart

    I don't know if this might help, but it is basically the same issue I had at first with the Vs 2013 solution. I created a VS 2012 solution with no  code except outputting a <h1> tag with some text. When I tried to deploy the code, I received the following:

    "Error 1 Error occurred in deployment step 'Activate Features': Feature with Id '2b07a52d-38b4-46ac-a6b5-46c07567013a' is not installed in this farm, and cannot be added to this scope.
      0 0 test"

    The environment does not seem to be working well.


    Sherazad


    • Edited by Sherazad Wednesday, May 28, 2014 3:55 PM edit
    Wednesday, May 28, 2014 3:54 PM
  • What is the scope of the project. If the scope is not site, try changing it to site and deploy.
    Wednesday, May 28, 2014 4:06 PM
  • Hi,

    Have tried all the scopes i.e. Site, farm, Web, Web Application. None allow me to deploy. Any other ideas?

    thanks,


    Sherazad

    Wednesday, May 28, 2014 5:19 PM
  • Can you send the screen shot of the Solution Explorer and the code.
    Wednesday, May 28, 2014 6:33 PM
  • Here is a screenshot of the code.


    Sherazad

    Wednesday, May 28, 2014 6:42 PM
  • Can you create the wsp package and try deploying it using stsadm or powershell

    This link may help

    http://blogs.msdn.com/b/calvarro/archive/2011/11/06/sharepoint-2010-amp-visual-studio-2010-error-ocurred-activate-features-feature-with-id-installed-in-this-farm-cannot-be-added-to-this-scope.aspx

    Wednesday, May 28, 2014 7:09 PM