none
Visual Studio 2015 sudden slow down

    Question

  • Hi I have a large asp.net solution with 8 projects in it. 

    the project is on 5 machines in total an is working fine on 4 of them and was working fine on the 5th on till yesterday when suddenly the build started taking longer and even simple task like logging in the the system when debugging started taking minuets not seconds.

    there is even one page that loads but then just sites there   and after a while chrome tells me that the page in not responding, I have also tiered use Edge and got similar results. 

    I have tried restart the system, reinstalling Visual studio and pulling a fresh copy of the code from source control but the problem persist. 

    there are no spikes in the CPU, Memory or disk usage of the system and otherwise seems to work fine. 

    the only thing that changed on the system side is that i installed source tree but i can see how that would effect it. 

    anyone got any idea's on what the issue could be or how to diagnose the issue. 


    Regards Dagz

    Friday, February 17, 2017 9:34 AM

Answers

  • Hi Dagz,

    Welcome to the MSDN forum.

    Does this slow issue only happens to the specific solution or any solutions even if the new solution? Since this solution works fine on other computer, this issue looks like more relates to the VS or this machines.

    Please have a try with the following to troubleshot this issue:

    1) Go to Tools > Options > Source Control and set Current source control … : None

    2) Go to Tools > Options > Environment > Synchronized Settings and remove this option by unchecking the checkbox.

    3) Clean the contents in the following cache folders (do not delete these folders, instead delete their contents only) and restart Visual Studio:

    1. Clean the content in WebSiteCache folder (can be found in
           C:\Users\%USERNAME%\AppData\Local\Microsoft\WebSiteCache)
    2. Clean the content in Temporary ASP.NET Files folder (can be found in
      C:\Users\%USERNAME%\AppData\Local\Temp\Temporary ASP.NET Files)

    4) Open the VS 2015 installation location, usually locates C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE and run the following commands. After each command, reopen VS to check this issue.

    1. devenv /resetuserdata: clear the old user data
    2. devenv /safemode: run the VS as safe, if it works fine that means the installed extensions may be corrupted the VS, please go to Tool—Extensions and Updates… and remove all installed extensions one by one to find the culprit.

    5) Temporarily disable antivirus and run as administrator

    6) Remove the .vs or .suo file of this asp.net solution and reopen this solution

    Best regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Dagz Monday, February 20, 2017 9:06 AM
    Monday, February 20, 2017 5:57 AM
    Moderator

All replies

  • Hi Dagz,

    Welcome to the MSDN forum.

    Does this slow issue only happens to the specific solution or any solutions even if the new solution? Since this solution works fine on other computer, this issue looks like more relates to the VS or this machines.

    Please have a try with the following to troubleshot this issue:

    1) Go to Tools > Options > Source Control and set Current source control … : None

    2) Go to Tools > Options > Environment > Synchronized Settings and remove this option by unchecking the checkbox.

    3) Clean the contents in the following cache folders (do not delete these folders, instead delete their contents only) and restart Visual Studio:

    1. Clean the content in WebSiteCache folder (can be found in
           C:\Users\%USERNAME%\AppData\Local\Microsoft\WebSiteCache)
    2. Clean the content in Temporary ASP.NET Files folder (can be found in
      C:\Users\%USERNAME%\AppData\Local\Temp\Temporary ASP.NET Files)

    4) Open the VS 2015 installation location, usually locates C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE and run the following commands. After each command, reopen VS to check this issue.

    1. devenv /resetuserdata: clear the old user data
    2. devenv /safemode: run the VS as safe, if it works fine that means the installed extensions may be corrupted the VS, please go to Tool—Extensions and Updates… and remove all installed extensions one by one to find the culprit.

    5) Temporarily disable antivirus and run as administrator

    6) Remove the .vs or .suo file of this asp.net solution and reopen this solution

    Best regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Dagz Monday, February 20, 2017 9:06 AM
    Monday, February 20, 2017 5:57 AM
    Moderator
  • Hi thanks for the help, simply doing steps 1 to 4 seems to has cured it so must have been something in the cache that was causing it. thanks. 


    Regards Dagz

    Monday, February 20, 2017 9:07 AM
  • Hi Dagz,

    It's my pleasure to help you solve this issue and thank you for your feedback :)

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, February 21, 2017 1:41 AM
    Moderator