locked
Starting Management Studio, got "Could not load file or assembly 'WindowsBase 4.0.0.0 ...'" error RRS feed

  • Question

  • "Could not load file or assembly 'WindowsBase 4.0.0.0 ...

    I get this error when starting Management Studio Express 2012.

    I know it is related to Visual Studio 2010 SP1. I ought to try to update VS2010 SP1 with KBxxxx that fix security issues. But one KB2635973 refuses to install (I downloaded the update and run it not via Windows Update). When running the update I get the same error. The update UI shows that it has been installed. But it was not. When I check Windows Update it would be listed again.

    I didn't invite this trouble myself. I was running Windows 8. I was constantly prompted to upgrade to 8.1 but I declined. But one day it just got upgraded anyway without giving any chance to abort the upgrade. Since then I have this "Could not load file or assembly" error.

    I had tried re-installing SQL server management studio. But the error refuses to go away.

    Please help as I have spent a lot of time searching for solution without success. I have been using DOS/Windows since the 1980's and this is the worst experience that I have come across.

    • Moved by Bob Beauchemin Friday, November 21, 2014 4:16 AM Moved to the forum for SSMS and other SQL Server tools
    Friday, November 21, 2014 4:09 AM

Answers

  • Ok I found the cause after browsing through this thread:

    http://stackoverflow.com/questions/14506938/could-not-load-file-or-assembly-windowsbase-version-4-0-0-0

    WindowsBase.DLL is missing from this folder on my machine:

    C:\Windows\Microsoft.NET\assembly\GAC_MSIL\WindowsBase\v4.0_4.0.0.0__31bf3856ad364e35

    I copied the file from another machine into this folder. Now the problem disappears.


    Friday, November 21, 2014 6:30 AM

All replies

  • Ok I found the cause after browsing through this thread:

    http://stackoverflow.com/questions/14506938/could-not-load-file-or-assembly-windowsbase-version-4-0-0-0

    WindowsBase.DLL is missing from this folder on my machine:

    C:\Windows\Microsoft.NET\assembly\GAC_MSIL\WindowsBase\v4.0_4.0.0.0__31bf3856ad364e35

    I copied the file from another machine into this folder. Now the problem disappears.


    Friday, November 21, 2014 6:30 AM
  • The folder containing the file requires administrator access. So I don't know how the file got deleted in the first place.
    Friday, November 21, 2014 6:38 AM
  • Hi Halmo2,


    Thanks for your post and glad to hear that the issue is resolved. I mark your reply as answer, that way, other community members could benefit from your sharing.


    Thanks,
    Lydia Zhang

    Monday, November 24, 2014 1:48 AM