locked
WinRT Custom Panel scrolling

    Question

  • I implemented custom Panel for custom layout items in ListView and put it to <ItemsPanelTemplate>. It's works, but is not possible to scroll. This answer not applicable because I'm using MVVM data binding. How to make scrolling work?
    Friday, January 09, 2015 10:46 AM

Answers

  • Hi SUDALV92,

    I think you missed the configuration of ScrollViewer like the following code.

    <ListView ScrollViewer.HorizontalScrollBarVisibility="Auto"
    
       ScrollViewer.HorizontalScrollMode="Enabled"
    
       ScrollViewer.VerticalScrollMode="Disabled"
    
    >
    

    Please modify to meet your requirement and try it. If not work, please post more information about your scenario.

    Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Tuesday, January 13, 2015 6:07 AM
    Moderator

All replies

  • The only way for scrolling to work is either give the panel a height so the framework knows when to turn one scrolling. Maybe giving the list view a height will work
    Friday, January 09, 2015 11:26 AM
  • I'm did try set height to the ListView, but scrolling still not work.

     <ListView ItemsSource="{Binding Feeds}" Height="450">
                <ListView.ItemsPanel>
                    <ItemsPanelTemplate>
                        <tools:StaggeredWrapPanel ItemWidth="500" />
                    </ItemsPanelTemplate>
                </ListView.ItemsPanel>
                <ListView.ItemTemplate>
                    <DataTemplate>
                        <Grid Background="#70000000">
                             <!--...-->
                        </Grid>
                    </DataTemplate>
                </ListView.ItemTemplate>
            </ListView>

    Friday, January 09, 2015 11:42 AM
  • Hi SUDALV92,

    I think you missed the configuration of ScrollViewer like the following code.

    <ListView ScrollViewer.HorizontalScrollBarVisibility="Auto"
    
       ScrollViewer.HorizontalScrollMode="Enabled"
    
       ScrollViewer.VerticalScrollMode="Disabled"
    
    >
    

    Please modify to meet your requirement and try it. If not work, please post more information about your scenario.

    Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Tuesday, January 13, 2015 6:07 AM
    Moderator