locked
Selection Box Name Tags RRS feed

  • Question

  • Whenever I copy a selection box, Expression always automatically changes and renumbers the tags like this:

    Copy:

    <select name="os0" size="1">

    Paste:

    <select name="os1" size="1">
    <select name="os2" size="1">
    <select name="os3" size="1">
    <select name="os4" size="1">
    <select name="os5" size="1">

    I do not want Expression to change the "os0" to "os1" etc.. each time I copy and paste the HTMl code.

    How can I make it stop indexing the tags each time I copy and paste?

    Thursday, December 2, 2010 8:15 PM

All replies

  • I don't Know if this setting applies to Name attributes, too, but there is a setting on the Tools|Page Editor Options|General tab, upper left, for "Make ID unique on paste." You can try unchecking that, then experimenting by pasting a select to see if that setting controls avoiding duplicate names, as well. Doesn't take long to test; worth a try...

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.
    Thursday, December 2, 2010 8:22 PM