none
WES2009 Harddisk boot RRS feed

  • Question

  • Hi

    I have created a WES2009 image for tunnel creek E6xx platform. since the SATA driver is not available, i have created and added the SATA component with Image and booted but it shows "No Operating system found" error. 

    I have created image and formatted my SATA hard disk by diskpart and copied all the release image folders but it is showing above error. 

    I have also tried with and without of USB2.0 boot options but it is not working.

    Any help on this?

    Thanks,

    Monday, October 5, 2015 5:04 PM

All replies

  • Do you press F6 to install a third party SCSI or RAID driver at the beginning of WES2009's installation? When prompted, select "S" to Specify Additional Device. 

    You should create a floppy* containing the following files in the root directory: iaAhci.inf, iaAhci.cat, iaStor.inf, iaStor.cat, iaStor.sys, and TxtSetup.oem.

    The following will show you how to install SATA driver before install WES2009: 

    https://www.youtube.com/watch?v=6oDT40ewh90

    Tuesday, October 6, 2015 2:00 AM
  • Can you be specific on the platform you are using? Make and Model?

    Sean Liming - Book Author: Starter Guide SIM (WEI), Pro Guide to WE8S & WES 7, Pro Guide to POS for .NET - www.annabooks.com / www.seanliming.com

    Tuesday, October 6, 2015 2:42 AM
    Moderator
  • Dear Bagira,

    I am using WES2009 (XP Embedded) and created a image to directly copy to the hard disk. Here, we can not use the F6 option which we used in Windows XP. Also, i have created the .sld file baed on the sata driver and inclued in the image but it is not working.

    Dear Sean,

    We are using the Intel tunnel creak platform to check the WES2009.

    My question is that, to boot the WES2009 image in SATA hard disk which i built from Target designer, it shows "No operating system found".

    Could you please provide your help on this whether do i need to add any new components regarding Hard disk boot or do i need to add any drivers?

    Thanks in advance.

    Tuesday, October 6, 2015 8:16 AM
  • IMO the message "No operating system found!" sounds more like a message from the system BIOS than from the WES2009 O/S.

    This usually happens if there is no active partition on the media. You can fix that by the "active" command in diskpart. Note: You should do that on a WinXP based system, "diskparting" on a Win7 system will write a Win7 style MBR to the media (in this case you would see a message "BOOTMGR missing" -> you may rename NTLDR to BOOTMGR, but I'm not sure about the consequences of that).

    The next thing you have to ensure is that the MBR is written to the media. The easiest way to get that fixed is to boot from XP[e] CD and run "fixboot" and/or "fixmbr".


    EDIT: Also check your boot sequence...
    • Edited by Willi K Tuesday, October 6, 2015 10:53 AM
    Tuesday, October 6, 2015 10:51 AM
  • Dear Willi,

    Thanks for your reply.

    I have used diskpart in windows 7 pc only. I have changed the name NTLDR to BOOTMGR but it is not working. I will try it with windows xp pc.

    The actual error is " Missing Operating System".

    I have below queries,

    i. I did not get the Windows XP embedded boot cd. I have only WES2009 which does not have boot option (does not have WinPE).

    ii. If i use the latest WinPE from Windows AIK, it shows error status 0xc000000f.

    What is the correct WinPE version should I use for WES2009? where we can download the Windows XP embedded boot CD?

    Thanks in advance.

    Tuesday, October 6, 2015 12:42 PM
  • Check the BIOS and see if there is a legacy IDE Mode for SATA. I think for WES2009 the legacy mode needs to be set.

    Sean Liming - Book Author: Starter Guide SIM (WEI), Pro Guide to WE8S & WES 7, Pro Guide to POS for .NET - www.annabooks.com / www.seanliming.com

    Tuesday, October 6, 2015 8:44 PM
    Moderator
  • Dear Sean,

    Thanks for your reply.

    I have checked it in BIOS and there are no option like legacy IDE mode. I have discussed with BIOS team and they informed that Intel tunnel creek platform (E6xx) will not support legacy IDE mode and there are no way to support it in BIOS.

    Can you please confirm that WES2009 image will not work without legacy IDE mode for SATA? Is there any microsoft link mentioned it?

    If i create image with old Windows XP embedded, the image will work without above settings?

    Thanks in advance.

    Wednesday, October 7, 2015 7:09 AM
  • I was surprised to see that the WES2009 DVD is not bootable. You do not need a XP Embedded CD - you also can use a common Windows XP CD (hope you have one) - the tools I have mentoined above are also included in common XP CDs.

    Regarding IDE/SATA mis-configuration: In such case you should have other troubles - with better words: A beautiful blue screen reporting a 0x7B exception.

    You told that your XPe-Image works. IMO WES2009 is only a XPe SP3 with some additional features - and should work as well. Have you really tried your XPe image with the same hardware you used to create your WES2009 image?

    Wednesday, October 7, 2015 11:39 AM
  • Dear Willi,

    Yes. I have created WES2009 image for same platform with USB pen drive and it is working. If i follow the same step in SATA hard disk, i am getting this error.

    Thanks,

    Wednesday, October 7, 2015 1:48 PM
  • Have you already tried to install a common XP from CD on that system to that SATA drive (you can install eval copy - this does not require a valid license)? Don't forget to feed the SATA drivers during setup (the "F6 install").

    One thing came into my mind: I remember about a system that did not boot from a secondary port (e.g. SATA 1) if nothing is attached to the primary port (SATA 0).
    Wednesday, October 7, 2015 2:21 PM
  • XPe would have the same issue. There is not link to share. It is just experience using WES2009 / XP Embedded.

    Try installing Windows 7 or WES7 on this system jus to verify some Windows version installs.

    Have you tried installing Windows XP SP3?


    Sean Liming - Book Author: Starter Guide SIM (WEI), Pro Guide to WE8S & WES 7, Pro Guide to POS for .NET - www.annabooks.com / www.seanliming.com

    Wednesday, October 7, 2015 7:10 PM
    Moderator
  • Dear Willi and Sean,

    thanks a lot for your inputs.

    In our board, there are two SATA ports (SATA1 and SATA2) available. SATA1 is connected to mSATA interface and SATA2 is connected to SATA hard disk.

    I have tried with SATA2 (SATA hard disk) and the image is not booting (Missing operating system )

    When i try the same image in SATA1 (mSATA), the Windows XP loading image is appeared but the PC is restarted within a sec. 

    Do we need to connect SATA1 mandatory to boot with OS? or Do we need to change any settings in BIOS or hardware or WES2009 to boot from first port?

    I have checked the hardware with Windows XP SP3, Windows 7, WES7 and all are working fine except WES2009.

    Do I need to add/ remove any components? Any inputs?

    Thanks in Advance.

    Thursday, October 8, 2015 7:07 AM
  • Hi,

    it seems that your system (BIOS) attempt to boot from the mSATA without any succes. This may happen if there is a valid valid (active) partition, but does not have an valid MBR. I'm not sure why your BIOS does not try the next boot device, but you have seen that it works after you swapped the medias. As mentoined before, changing the boot sequence may be an option (configure HDD as the first boot device or similar).

    Unfortunately I cannot explain why other O/S worked without that changes. One POSSIBLE explaination (XP Pro for example): Setup installed boot code on mSATA and the O/S to the HDD. As a result of that BIOS will load MBR from mSATA with success, which finally loads O/S from HDD. BUT: In that case you might see BOOT.INI and NTLDR on the mSATA module. If so, your WES2009 should now boot as well.

    Regarding the reboot: It seems that your WES2009 crashes (option "Reboot on system failure"). You can use the "Disable automatic restart on system failure" in the startup options menu (pres F8 [many times] before O/S starts). I'm quite sure that you will see a 0x7B exception. This usually happens if windows uses the wrong drivers (for example loads drivers for IDE instead of SATA in your case).

    Thursday, October 8, 2015 9:16 AM
  • Dear willi,

    Thanks.

    I disabled "automatic restart on system failure" in F8 setup and now i am getting 0x7B exception as you mentioned.

    I have added the SATA driver which Intel provided for windows xp for floppy disk during XP installation which we used for desktop Windows XP installation. 

    Do we need to install any other driver? I have a driver for Windows 7 and i tried the same for XPe but it is not working.

    Thanks in Advance.

    Thursday, October 8, 2015 9:29 AM
  • Dear Willi,

    Also, i have formatted my mSATA in Windows 7 PC using diskpart. Does it affect for 0x7E issue? If so, i will also try to format with Windows XP PC.

    Also, in the mSATA, i have seen NTLDR and BOOT.ini files. 

    Thanks,

    Thursday, October 8, 2015 9:37 AM
  • It should not make a difference if you are using Win7 or WinXP for formatting. Only diskpart may be critical when using the "active" option since Win7 diskpart will write Win7 MBR in that case.

    There are some things that may caused your 0x7B exception (besides real HW problem, but since XP runs fine this is not the problem):

    • Your image does not support the file system. If you formatted using NTFS, you also need the NTFS file sytem component and others related to it in your image
    • Your image still loads drivers for common IDE controllers. In your initial post you already mentoined that you created and added a Component for the SATA controller, usually that should work that way. Does the bluescreen display any file names?
    • The NTLDR and BOOT.ini on the mSATA brought me to another assumption: Do you have EWF included in your image? If so, NTLDR is another (need to add the "EWF NTLDR" to your image).

    Thursday, October 8, 2015 2:35 PM
  • Dear Willi,

    Thanks for your input.

    i. I have used "active" option in win7 OS. I will check with WinXP and inform you.

    ii. I have formatted with NTFS. can you please mention that do i need to add any components for this? If there are any links which mentions the required component, can you please point out?

    iii. The BSOD did not mention any file name. Is there any way to identify which component missing/required caused for this BSOD. In Windows device driver development, we will use WinDBG. Is there any equivalent tool for WES2009?

    iv. I have added "EWF NTLDR" but the behavior is same. When I try to add "EWF NTLDR" it asks to remove he "NT loader". so i removed it but it is not working.

    Thanks in advance.

    Tuesday, October 13, 2015 3:52 AM
  • Hello Mary Net,

    did you performed an dependency check (you can try with "Auto resolve" disabled to see what becomes introduced)? However, resolving the dependencies manually will help reducing the footprint, but on the other side this may be a daunting task.

    Regarding NTFS you may search for components having NTFS in the display name. AFIAIK you need "NTFS" and "NTFS Format" at least, adding the other may help while you try to find the cause of your problem.

    You may use WinDbg to analyse dump file / debug with XP SP3 symbols. But I cannot grant for any success.

    At least I have no more advice at the moment.

    Friday, October 16, 2015 7:06 AM