locked
a selected drive no longer valid RRS feed

  • Question

  • I have been using Visual Basic 2008 Professional, with no problem. I tried to add Visual C# but get the error :A selected drive is no longer valid. Please review your installation path settings before continuing with setup"

    A previous post suggested that all updates be removed and the problem would be resolved. However, I still get the error.  Can anyone help?


    sirmilt
    Wednesday, April 6, 2011 12:11 AM

Answers

  • Thanks to all who tried to help.

    When I tried to unistall the Visual Studio SP1 I mistakenly (or was it carelessly) unistalled an update other then SP1. I discovered the problem late yesterday, unistalled SP1 and the problem went away, I was able to add the C#.

    Thanks again for all the suggestions and help.

    Milt


    sirmilt
    • Marked as answer by sirMilt Thursday, April 7, 2011 1:23 PM
    Thursday, April 7, 2011 1:23 PM

All replies

  • Did you install it from an .iso on a mounted drive?  Or from a physical disk?
    n00b
    Wednesday, April 6, 2011 1:27 PM
  • clevestone

    Thank you for the response, I installed from a physical disk.


    sirmilt
    Wednesday, April 6, 2011 6:00 PM
  • clevesteve

    sorry for the way I mangled your ID

    Milt


    sirmilt
    Wednesday, April 6, 2011 6:02 PM
  • Hi Milt,

    Welcome to the MSDN Forum.

    First, there are several things I would like to clarify with you:

    • Would you please let me know your OS version?
    • Do you have installed the Visual Studio 2008 Professional instead of the "Visual Basic 2008 Professional", and now you would like to add VC# feature to your Visual Studio?

    I've found one of your pervious post asked a similar issue: http://social.msdn.microsoft.com/Forums/en/vssetup/thread/a2d61de4-bc26-4831-a40d-8e7c8ce444ed. So remove the VS 2008 SP1 still not resolve your problem?

    In this case, would you please follow the steps below to collect the installation logs for me?

    • Please go to Control Panel -> Programs -> View installed updates, and make sure all updates for Visual Studio 2008 has been uninstalled;
    • Turn off your anti-virus/antispyware software;
    • Clean your %temp% folder (Start Menu >> Run >> Type "%temp%)
    • Please go to Control Panel -> Uninstall a program -> right-click the Visual Studio 2008 Professional in the program list -> choose Uninstall/Change;
    • Choose Add or Remove Features, select the checkbox of Visual C# node. Click Update to start install;
    • Collect the logs from "%temp%" folder with the Log Collection Tool
      Collect tool: http://go.microsoft.com/?LinkId=8967044
    • Send the vslogs.cab file in the %temp% folder to me (E-mail: v-anwu@microsoft.com). 
      Note: Please attach the link of this post in the mail.

    If you have any concerns, please feel free to let me know.

    Best Regards, 


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, April 7, 2011 8:55 AM
  • I think the fastest way to resolve this issue is to re-install your VS 2008. You can use this uninstall tool: http://blogs.msdn.com/b/joy/archive/2009/10/16/microsoft-visual-studio-2008-rc-rtm-uninstall-tool.aspx to get it fully uninstalled.

    And steps to manually uninstall: http://blogs.msdn.com/b/joy/archive/2008/10/21/how-to-remove-visual-studio-2008-manually.aspx

    Before install VS, disable your anti-virus app and clean your %tepm% folder, then run the setup with Run as administrator. This time, remember select both of VB and VC#. 

    Thursday, April 7, 2011 11:29 AM
  • Thanks to all who tried to help.

    When I tried to unistall the Visual Studio SP1 I mistakenly (or was it carelessly) unistalled an update other then SP1. I discovered the problem late yesterday, unistalled SP1 and the problem went away, I was able to add the C#.

    Thanks again for all the suggestions and help.

    Milt


    sirmilt
    • Marked as answer by sirMilt Thursday, April 7, 2011 1:23 PM
    Thursday, April 7, 2011 1:23 PM