locked
problem about using the synchronous command in installation RRS feed

  • Question

  •     i have created an answer file call practice.xml, the answer file contains one synchronous command in audituser pass. the settings in ICE show as below: 

    path: cmd /c c:\qq2010beta2.exe

    order: 1

     i use the OEM folder to copy the qq2010beta2.exe to the c:\ root path,  but unfortunately , this command didn't run when i installed the image to a machine, i have tried several times, i never find this command run. so i created another answer file only contain this synchronous command, it called syncommand.xml. i copied this answer file to my u disk, and plugged it into the machine, then i run command "sysprep /audit  /unattend:e:\syncommand.xml" . the system started to clean the machine-related information , another time the system boots up, this synchrous command run,start to install this software. so what is the problem with practice.xml answer file? i am really puzzled by this problem.

    Tuesday, April 13, 2010 7:02 AM

Answers

  • I believe this behavior is by design.  If you reference the auditUser topic in ICE Help, it says:

    auditUser runs only when you configure Image Builder to start in audit mode. You can start in audit mode by usingsysprep /audit, or sysprep /generalize /audit.

    Hope it helps.

    Ivan

    Thursday, April 15, 2010 11:59 PM

All replies

  • I have also added another  synchronous command in OOBE pass, it can work normally.
    Wednesday, April 14, 2010 2:12 AM
  • I believe this behavior is by design.  If you reference the auditUser topic in ICE Help, it says:

    auditUser runs only when you configure Image Builder to start in audit mode. You can start in audit mode by usingsysprep /audit, or sysprep /generalize /audit.

    Hope it helps.

    Ivan

    Thursday, April 15, 2010 11:59 PM
  • I believe this behavior is by design.  If you reference the auditUser topic in ICE Help, it says:

    auditUser runs only when you configure Image Builder to start in audit mode. You can start in audit mode by usingsysprep /audit, or sysprep /generalize/audit.

    Hope it helps.

    Ivan


    hi Ivan,

        thanks. because i saw  there are 4 options in the "insert-> synchronous command" menu:pass 1,pass 4,pass 6, pass 7. then i regarded that the audituser should can be run in installation. but you are right, i also find another description as such :"Not all configuration passes run in a given installation of Standard 7. Some passes, such asauditSystem and auditUser, run only if you start in audit mode" in "how configuration pass work" subtitle.

    Friday, April 16, 2010 5:32 AM