none
Proper .net framework for compilers RRS feed

  • Question

  • I have about a dozen programs and most of them are written using VB2008. I know VB2008 is not supported and I also have VS2012 and VS2019. One reason for not updating them is when I try and move them to a newer compiler, they want upgraded from .NET 2.0 framework. What is the best framework to use for the 2012 & 2019 compilers?
    • Edited by Douglas Harter Saturday, February 15, 2020 12:02 AM misspelling
    Saturday, February 15, 2020 12:01 AM

All replies

  • I would use .net 4.5.2 or newer.   Earlier versions are not supported.
    Saturday, February 15, 2020 11:29 AM
  • For more information about supported versions of the .Net Framework and Microsoft's related policy see -

    https://dotnet.microsoft.com/platform/support/policy/dotnet-framework

    and

    https://support.microsoft.com/en-us/help/17455/lifecycle-faq-net-framework

    Saturday, February 15, 2020 12:29 PM
  • Hi Douglas Harter,

    Sorry for delay in reply.

    For your requirement, the .NET fromwork 4.5.2 seems to be better choice for you, which support all windows system and is compatible with VS2012 and VS 2019.

    About more info about .Net framework, please refer here: Determine which .NET Framework versions are installed 

    Hope it could help you.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, February 17, 2020 3:50 AM
  • Thanks Dylan  & Ken.

    Using Dylan's instructions, I looked up my installed framework. I only have 4.8. I have already downloaded & tried to install 4.5.2. The system wouldn't let me because I have 4.8 installed. I reset the Target Framework for my smallest program to 4.5.2. The program needed mscorlib from 4.5.2, but I didn't have that installed. mscorlib is in the reference list, but it said I needed the one for 4.5.2. How can I set the framework so I can get the mscorlib? 4.8 is not in the framework list. Also, do I need or want the Development packs for 4.8?





    20 hours 25 minutes ago