none
Cannot create connector - e destination component does not have any available inputs for use in creating path

    Question

  • I am trying to create DTSX package to do ETL from SharePoint list to SQL Server table. When I am trying to connect I am getting “The destination component does not have any available inputs for use in creating path”. Please help me to understand why I am getting this error dialog box.


    Thanks & Regards, Santhosh
    Thursday, July 14, 2011 10:55 AM

Answers

  • I figured out what was my mistake. I was using OLE DB source insted of destination. Thanks for your helpful suggestions.


    Thanks & Regards, Santhosh
    Friday, July 15, 2011 9:48 AM

All replies

  • What destination component are you using?
    How are you trying to connect it?


    MCTS, MCITP - Please mark posts as answered where appropriate.
    Thursday, July 14, 2011 11:00 AM
  • I am using OLE DB destination and trying to connect SharePoint List Source connector to OLE DB destination.
    Thanks & Regards, Santhosh
    Thursday, July 14, 2011 4:42 PM
  • Do you have any other transforms in your data flow?  If so, how are they connected?


    Todd McDermid's Blog Talk to me now on
    Friday, July 15, 2011 4:23 AM
    Moderator
  • Right now I am using only one transformation. I checked it in other packages I have no issue while connecting. Is it because of SharePoint List Source I am facing this issue? If so, do I need to install any other components to support? Please help.


    Thanks & Regards, Santhosh
    Friday, July 15, 2011 5:26 AM
  • Did you already configure the Sharepoint Source? Does it have output columns?
    MCTS, MCITP - Please mark posts as answered where appropriate.
    Friday, July 15, 2011 5:49 AM
  • Yes I have configured SharePoint List Source and it has 3 columns for output and I have same 3 columns in OLE DB destination table as well.


    Thanks & Regards, Santhosh
    Friday, July 15, 2011 6:43 AM
  • Yes I have configured SharePoint List Source and it has 3 columns for output and I have same 3 columns in OLE DB destination table as well.


    Thanks & Regards, Santhosh

    Can you post a screenshot of what you're doing when this error happens?
    MCTS, MCITP - Please mark posts as answered where appropriate.
    Friday, July 15, 2011 6:51 AM
  • I am not able to post screenshot. if ur ok to give your email address I'll send it you.
    Thanks & Regards, Santhosh
    Friday, July 15, 2011 6:59 AM
  • Using below link I have installed SharePoint List source and destination:

    http://msdn.microsoft.com/en-us/library/dd365137(v=sql.100).aspx

    Please help is anything else do I need to install.


    Thanks & Regards, Santhosh
    Friday, July 15, 2011 9:04 AM
  • I figured out what was my mistake. I was using OLE DB source insted of destination. Thanks for your helpful suggestions.


    Thanks & Regards, Santhosh
    Friday, July 15, 2011 9:48 AM
  • I figured out what was my mistake. I was using OLE DB source insted of destination. Thanks for your helpful suggestions.


    Thanks & Regards, Santhosh

    Ah ok :)
    A screenshot would have helped to locate this problem sooner, but I didn't find a way to send you a personal message.
    MCTS, MCITP - Please mark posts as answered where appropriate. Answer #1: Have you tried turning it off and on again? Answer #2: It depends...
    Friday, July 15, 2011 10:18 AM
  • lolz :P I was facing same issue :D
    Thursday, November 21, 2013 9:36 AM