Lease Blob on Development Storage seems to ignore active leases RRS feed

  • Question

  • Some strange behaviour going on. Try the following on the development storage service:

    1. Create a new blob container
    2. Create a new blob and upload some data in it
    3. Acquire a lease for the blob
    4. Try updating the blob's data without specifying the lease ID.

    Notice that updating blob contents is possible when the blob has an active lease and you do not specify the lease ID to the storage service. Is this a difference between production and development storage? If so, can this be added in the MSDN documentation?

    Tuesday, April 20, 2010 9:19 AM


All replies

  • That certainly seems strange.  Have you tried the same code against cloud storage (to verify it fails)?
    Tuesday, April 20, 2010 4:46 PM
  • Haven't tried it on cloud storage yet. Should leases work as expected on dev storage?
    Tuesday, April 20, 2010 5:04 PM
  • Well, I think we can all agree they should. :)  As to whether there are known issues, I don't know, but I'll ask.
    Tuesday, April 20, 2010 5:05 PM
  • Maarten, I've verified the issue using my own code from http://blog.smarx.com/posts/leasing-windows-azure-blobs-using-the-storage-client-library... this certainly seems like a bug in development storage.  I'll flag it for the appropriate folks on the team.

    • Marked as answer by maartenba02 Tuesday, April 20, 2010 5:32 PM
    Tuesday, April 20, 2010 5:17 PM
  • Perfect, thanks!
    Tuesday, April 20, 2010 5:32 PM
  • I'm not sure if this is a symptom of the same bug, or a different one, but when running against dev storage, I'm finding that blob leases do not expire as expected.  For example:

    -Aquire a one minute lease
    -Wait 2 minutes
    -Try to aquire another one minute lease

    On dev storage the second aquire fails with a 409.  On production storage, it succeeds.


    Wednesday, September 15, 2010 6:47 PM
  • Yes, this is a related (known) issue.
    Wednesday, September 15, 2010 10:07 PM