locked
Mail not send through msdb.dbo.sp_send_dbmail when @Body contains a period(.) character RRS feed

  • Question

  • Hi,

    I am trying to use sp_send_dbmail to send a custom email. I am essentially using this for sending some custom alerts.

    When I execute the following it works fine. I get the 'mail queued' message and I recieve the mail in mail account.

    EXEC msdb.dbo.sp_send_dbmail
    @recipients='jithin.jerald@xyz.com',
    @subject
    = 'Trial',
    @Body
    = 'Blank Message',
    @profile_name
    = 'SQL Alert'


    But when I execute the same with a period character (.) , it just shows up as "mail queued" but I never recieve it to my mail account.

    EXEC msdb.dbo.sp_send_dbmail
    @recipients
    ='jithin.jerald@xyz.com',
    @subject
    = 'Trial',
    @Body
    = 'Blank Message.',
    @profile_name
    = 'SQL Alert'

    Due to this reaason I am not able to send any decimal values either which is what my original intent was.
    Any help is much appreciated and apologize in advance if this is a stupid question.

     

     

     

    Wednesday, November 18, 2009 7:20 PM

All replies

  • Hi,

    There's an optional parameter for sp_send_dbmail,

    [ @body_format = ] 'body_format'

    In that parameter, the default value is "TEXT", you can pass "HTML" in your case, and try to check if it works.

    Thanks.


    Microsoft Online Community Support Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, November 24, 2009 3:27 AM