locked
SQL Server Management Studio - Save Results As ... How can I default to ANSI ? RRS feed

  • Question

  • SQl Server 2012 - Management Studio 11.0.2100.60

    When doing a "Save Results As...", the results (.csv, .txt) are currently saved with UTF-8 encoding. Is there a way to set the default to ANSI?

    Yea, yea, I know that I can click on the "Save" down-arrow and select the approriate encoding. I would just prefer to not have to go through that step since I always want ANSI results.

    Also, I've found that FTP software can't transfer UTF-8 files correctly.

    Rich


    Friday, July 19, 2013 5:02 PM

All replies

  • Hi Rich,

    As you post, the save dialog has such an option by clicking the down arrow on the button where you can change your encoding method.
     
    If you install the SQL Server 2005 on your computer, the default for how files are saved is determined by the way of the main template file( SQLFile.sql), which located at C:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7 \IDE\sqlworkbenchprojectitems\Sql\. 
     If you save this file using ANSI encoding, then subsequent new query sessions will use this encoding.

    There is a similar issue about how to set the default to ANSI, you can review the following link.
    http://connect.microsoft.com/SQLServer/feedback/details/288677/unicode-defaults-on-ssms-save

    Thanks,
    Sofiya Li

    Sofiya Li
    TechNet Community Support

    Sunday, July 21, 2013 3:25 AM