Where can I find NET Framework 3.0/3.5 Configuration Tool RRS feed

  • Question

  • Where can I find .NET Framework 3.0/3.5 Configuration Tool and Code Access Security Policy Tool? They simply disappeared after Frameworks 1.1/2.0.



    Thursday, November 22, 2007 8:26 PM


All replies

  • In .net framework 3.0, the tool Mscorcfg.msc is installed with the .NET Framework SDK(2.0). In .net framework 3.5, the tool Mscorcfg.msc is installed with the Windows Software Development Kit (SDK).

    For Code Access Security Policy Tool, you can use Code Access Security Policy Tool (Caspol.exe) instead.
    Monday, November 26, 2007 6:41 AM
  • I'm also looking for Mscorcfg.msc for the .net framework 3.5 that I need to use with Visual Studio 2008 RTM.  I'm having security issues, involving code that sits on a network share, that I need to be resolve.  With Visual Studio 2005, I just use Mscorcfg that's installed with .net framework 2.0 SDK as part of the Visual Studio 2005 installation.


    I've reinstalled the .net framework 3.5 (200 MB) but it's still no where to be seen.  Is there an additional SDK for version 3.5 of the framework that is not installed with Visual Studio 2008?  If so could you provide a link to that download site?  Or, has Mscorcfg.msc gone away and we now need to use caspol.exe?  If so, the only copy that I found was part of the 2.0 framework.


    It was never a big problem to resolve on Visual Studio 2005.  Have I missed something?  Thanks in advance for your help.




    Wednesday, November 28, 2007 1:09 AM
  • In .net framework 3.5, the tool Mscorcfg.msc is installed with the Windows Software Development Kit (SDK).
    Wednesday, November 28, 2007 1:52 AM
  • Thanks very much for the information.  I was able to get the Windows SDK and when it installed, I did find the mscorccfg.msc file and dll.  Unfortunately, when I tried to get it up and running, I got an MMC error stating "Snap-in failed to initialize."  This is the same error message I get when I tried to start up the mscorcfg.msc file that was part of XP's SP2.


    Given all this should I just use Caspol.exe?  If so, does it make a difference which one I use (there are multiple copies installed).  For example, I have Visual Studio 2008 installed and want to create applications with versions 2.0, 3.0, and 3.5 of the .net framework.  Can I use the caspol.exe that is part of the 2.0 framework and have no problems with security for applications using the 3.5 framework?  Also, any recommendations on what parameters to use when using caspol.exe?  Again, thanks in advance for your help, I really appreciate it.



    Thursday, November 29, 2007 5:52 PM
  • The .net 3.5 and 3.0 use the same core runtime with .net 2.0, so you can caspol.exe of .net 2.0 for the 3 versions of assembly.


    What parameters of CASPOL.exe? This depends on what exactly you want to achieve.

    Friday, November 30, 2007 12:09 AM
  • I have visual studio 2008 professional installed (full install) and just installed the Microsoft Windows SKD V 6.1 on my Vista Home Premium 64 bit OS, no mscorcfg.msc can be found in windows find. I even set it to search whole computer and hidden, system, non indexed files. 

    Where the hell is this thing located????  I need to add in a network share as a trusted space for projects.


    Scott Emick

    Saturday, March 1, 2008 7:58 PM
  • Ok for those out there who run into the same problem as me, just use caspol.exe.  There is no mscorcfg.msc in the SDK like some people would like to think.  It is simply not there.  Maybe the people who claim to have mscorcfg.msc have older versions of visual studio or Windows SDK installed or an earlier version of dotnet. 

    My configuration is Windows Vista Home Premium 64 with VS 2008 professional only.  And, even downloading and installing the Windows SDK 2008 didn't give me caspol.msc either so don't bother.

    to add a trusted share, it is easy like this:

    CasPol.exe -m -ag 1.2 -url file://vistapc/vs2008/* FullTrust

    Scott Emick
    Euclid Friendly Computer Service

    Wednesday, March 5, 2008 8:57 PM
  • Yes but Caspol seems to work with .net 2.0 (just look at any version # it shows) . I am wondering as how to get it working with 3.0/3.5!


    Tuesday, March 11, 2008 6:03 PM
  • Could someone provide the link from which to download the Windows SDK version that contains the .NET 3.5 Configuration Utility?  Then link included earlier in this conversation doesn't work.

    I'm running Windows XP, for what that's worth.

    Also, was there a coherent reason not to include the Configuration Utility in the Visual Studio 2008 install, for Christ's sake?


    Monday, March 31, 2008 7:53 PM
  • There is no separate configuration utility for the .Net Framework 3.0 and 3.5.   The version 2.0 configuration utility is the correct one to use for v2.0, v3.0, and v3.5


    Here is an article that you might find interesting:
    Monday, April 14, 2008 4:45 PM
  • Thanks that article is awesome....Most of it I already know, but it is very thorough and encompasses many scenarios.




    Saturday, April 26, 2008 2:35 AM
  • If there is no mscorcfg.msc in framework 3.5 maybe someone should update the MSDN documentation. I wasted a lot of time finding a solution to distribute the settings made with caspol.exe on our corporate network using group policies. Any ideas?
    Tuesday, June 24, 2008 2:04 PM

    I believe this msdn article helps explain the confusion.
    • Proposed as answer by Paul B Felix Thursday, April 30, 2009 5:19 PM
    Thursday, April 30, 2009 5:19 PM
  • I truly do not understand Microsoft.
    DLL ____ was a cinch compared to the mess they created with this .net pseudo security. What good is it if you can't run an app from a network drive from within your own domain? 2 hours of research on this bs, and no one has answers, there are no fixes, and my users wait. Microsoft's problem is they can never sit still, they always want to reinvent themselves and their ____. How the fug can you distribute the monolithic .net.3.5 and not include a config utility!!!??? A$$holes
    Wednesday, December 23, 2009 8:02 PM
  • I'm using Windows Server Standard 2008 SP2 and already installed Microsoft SDKs (v7.0A).  My environment has Visual Studio Team System 2008 Development Edition with .NET Framework Version 3.5 SP1.

    But, I cannot find "mscorcfg.msc" in my environment.

    It was true that mscorcfg.msc was placed in %SystemDrive%\Program Files\Microsoft Visual Studio 8\SDK\v2.0\Bin.

    Where can I obtain "mscorcfg.msc" or how can I reproduce it with MMC?

    A true and confirmed information will be highly appreciated.

    Wednesday, January 20, 2010 9:06 AM
  • For the time being, I have settled on installing the tools only from VS2005 setup DVD so as to get mscorcfg.msc.

    Thursday, January 28, 2010 8:08 PM
  • what type of use .net 3.0 it means u use it with 2.0 so send me how to use with or without.

    then reply soon

    Saturday, August 14, 2010 7:01 AM
  • send me your confusion.



    Saturday, August 14, 2010 7:03 AM