locked
Receive error message 0x534 after changing the domain name RRS feed

  • Question

  • Hello,

     

    After changing the domain name I am receiving the following error message

    An exception occurred while enqueueing a message in the target queue. Error: 15404, State: 11. Could not obtain information about Windows NT group/user 'RHA-DC\administrator', error code 0x534.

    I have changed all the services to the changed name.


    Any ideas?

     

    Thanks for all your help in advance

    Friday, June 3, 2011 12:51 PM

All replies

  • May be a problem with SIDs , try dropping and re-creating windows domain accounts . That's just a guess
    Thanks, Leks
    Sunday, June 5, 2011 10:52 PM
  • May be a problem with SIDs , try dropping and re-creating windows domain accounts . That's just a guess
    Thanks, Leks


    Lekss is correct! Here is little more info.
    Hex 0x534 = decimal 1332
    On command prompt you can do net helpmsg 1332 and output is "No mapping between account names and security IDs was done"

    This essentially points to what Lekss is saying. Even if the account name is same, SID is different. Deleting and recreating login from SQL Server is the way to go.


    Balmukund Lakhani | Please mark solved if I've answered your question, vote for it as helpful to help other user's find a solution quicker
    --------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
    --------------------------------------------------------------------------------
    My Blog: http://blogs.msdn.com/blakhani
    Team Blog: http://blogs.msdn.com/sqlserverfaq
    Monday, June 6, 2011 6:44 AM
  • Where would I delete the account from, you state SQL Server but when I try to open the SQL Server Configuration Manager I get the following error message "Cannot connect to WMI provider. You do not have permission or the server is unreachable. Note that you can only manage SQL Server 2005 and later servers with SQL Server Configuration Manager. Invalid Class [0x80041010]"

     

    Would it be easier to just create a new domain account and assign SQL to this account.

    The acocunt that I am presently using is a domain admin account. I know its not wise but I was testing and I durting the course changed the name of the domain admin account.

     

    It might be wiser to change the domain account, if so how can I accomplish this.

     

    Thank you

    Monday, June 6, 2011 4:00 PM
  • Hi,
    If you change server’s domain and the server is running SQL Server. You need to take care of the below items:
    1. SA Access
    If you only have SQL Server sysadmin via domain accounts/groups, you should temporarily enable the sa account and ensure you know the password, until you get the new domain sysadmin accounts/groups working.
    2. Service Account
    The new domain service account(s) will need the same privileges as the old domain service accounts.
    3. SQL Server Domain-based Logins
    Logins that are based on domain accounts or domain groups will need to be recreated.
    4. Changing IP Addresses
    If required by the domain change and it's clustered, then the virtual server IP address must change in addition to the individual nodes.
    5. Service Principal Names (SPNs).
     If the IP addresses are changing, the old SPNs need to be dropped and new ones created. If the SQL Server service account is used to manage its own SPNs (not recommended) then the new domain service account will need to be granted the "Write servicePrincipalName" privilege.
    Hope this helps.

    Best Regards,
    Peja

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, June 7, 2011 6:17 AM
  • Hi,

     

    I am not changing domain but rather just wanting to change the account that is presently being used by SQL

    Wednesday, June 8, 2011 12:07 PM