none
Permissions needed to upload a document to a document library with folders RRS feed

  • Question

  • I'm using WSS 3.0 (not sure if SP1 has been applied)

     

    I'm trying to fully understand the permissions on document libraries, folders within document libraries and uploading files.

     

    It has been my observations that for the the following scenario:

     

    Document Library A

    Folder A

     

    Permissions:

    Document Library A - User A: Full Control; User B: Read

    Folder A - User A: Full Control; User B: Contribute; User C: Contribute

     

    Upload File to Folder A:

    User A: Yes; User B: Yes; User C: Access Denied

     

    I have been creating document libraries and I'm trying to tie down the permissions to various folders within the document library. I want User C to be able to only read and write to the contents of Folder A but to have no access to anything stored at the Document Library A root level.

     

    When User C browses to the Folder A, they can see the Upload Document menu option but as soon as they select it they get the Access Denied error message. I have found that if I give User C read permission at the Document Library level then they are able to Upload a document to Folder A.

     

    Can anyone shed any light on this? Perhaps a pointer to an area within the documentation that explains this scenario.

     

    Cheers,

     

    Colin

    Monday, May 12, 2008 3:12 PM

All replies

  • Colin,

     

    In all tests I have done I cannot duplicate what you are explaining here.  Could you clarify the following points for anyone else reading this post:

     

    - Have you changed any of the out of the box permission levels (for example, is Contribute setup as the default one or have you adjusted it)

    - Does User C have READ access to the rest of the site, with the exception of Document Library A?

     

    Thanks,


    Paul Liebrand

    http://liebrand.wordpress.com

     

    Monday, May 12, 2008 4:18 PM
  •  

    Hi Colin,

    If I understand you correctly you can overcome your scenario by setting up permissions directly at the folder level.  Then you can specify who has access to what folders and documents underneath the folders.  To do this create your folder and add some documents underneath the folder.  Then click on the drop down arrow next to the folder and select Manage Permissions.  From there you can specify groups/users and what access they have.  Please let me know if you need further guidance.

    HTH

    Jason Medero
    www.sharepointblogs.com/jasonmedero
    Monday, May 12, 2008 4:57 PM
  • Hi Paul,

     

    Thanks for the feedback. The permission levels on the site I manage are being inherited from a parent site, from what I can tell the permission levels have not been changed from the default settings so I *should* be using the standard Contribute permission.

     

    User C does have access to the rest of the site, just out of interest in your test what do you see; can User C upload documents successfully to Folder A.

     

    In order to make sure that it is not something special with my configuration I have registered for the  "TechNet Virtual Lab: What's New in Microsoft Windows SharePoint Services 3.0 Feature Walkthrough" and re-created the scenario above (I added users to the virtual machine then used the SharePoint "Sign in as Different User" menu option to login as User B and User C). I see the *exact* same results: User B is able to upload a document; User C is presented with the Access Denied error message when they click on the Upload Document menu option.

     

    So, from my experience what I am describing seems to be correct. To re-iterate what I did on the Virtual lab:

     

    1. Create two users: UserB; UserC

    2. Create a new site collection: Test

    3. Browse to the new top level site in the site collection (currently logged on as the LITWAREINC\Administrator, shows on SharePoint as System Account).

    4. Add UserB and UserC to the default Members group

    5. Create a document library called Test Lib

    6. Within the Test Lib document library create a folder called Folder A

    7. Configure the explicit permissions on the Test Lib document library to the following: Owners group - Full Control; UserB - Read

    8. Configure the explicit permissions on the Folder A folder to the following: Owners group - Full Control; UserB - Contribute; UserC - Contribute

    9. Log onto SharePoint as UserB using the Sign in as Different User menu option

    10. Browse to the Test Lib\Folder A folder.

    11. Hit the Upload menu option, presented with the Upload Document screen - success

    12. Long onto SharePoint as UserC using the Sign in as Different User menu option

    13. Browse to the Test Lib\Folder A folder

    14. Hit the Upload menu option - Access Denied error

     

    All I want to do is confirm that what I see is what is supposed to happen and if so is it documented anywhere.

     

    Cheers,

     

    Colin

    Tuesday, May 13, 2008 9:48 AM
  • Hi Jason,

     

    Thanks for your feedback. I'm sorry if my original post was not clear enough but I am setting permissions directly at the folder level.

     

    Cheers,

     

    Colin

     

    Tuesday, May 13, 2008 10:06 AM
  • Colin,
    I am seeing exactly what you are seeing and would like to know if this is "be design" and if so is there any documentation on this.

    It appears users MUST be listed with a minimum of Read access to a library in order to access documents at the folder or document level. Adding them only to the folder or document's permissions (where they appear as "limited access" to the overall library's permissions) seems to be an issue. Once I add the "limited access" user as a reader to the library, they can then access the documents in the folder in which they have been granted access.

    Also, in some cases we get an "Access Denied" issue and in other cases, we get a mis-leading "Excel Services" error.

    I would have thought that the user would not have been required to be added to the overall library, but that does not seem to be the case. We have not yet installed SP1, so maybe this is addressed and resolved with SP1. Anyone know?
    Thursday, December 11, 2008 8:00 PM