locked
SharePoint suspends workflows 2013 with HTTP unauthorized error after the reinstallation Workflow Manager RRS feed

  • Question

  • Hi everybody.

    After I uninstalled Workflow Manager, installed it again and reregistered SPWorkflowService I cannot run any workflow 2013. Workflow fails with HTTP unauthorized error, even if it only Logs to History List. I can create workflows 2013, edit, deploy them but not execute. Please help me to found the solution.


    Thursday, December 15, 2016 10:28 AM

Answers

  • Thank you, I have found the solution.

    Here is a part of ULS Log:

    SPApplicationAuthenticationModule: Invalid token or signature. Exception: System.IdentityModel.Tokens.SecurityTokenException: Invalid JWT token. Could not resolve issuer token.     at Microsoft.IdentityModel.S2S.Tokens.JsonWebSecurityTokenHandler.ReadTokenCore(String token, Boolean isActorToken)     at Microsoft.IdentityModel.S2S.Tokens.JsonWebSecurityTokenHandler.ReadActor(IDictionary`2 payload)     at Microsoft.IdentityModel.S2S.Tokens.JsonWebSecurityTokenHandler.ReadTokenCore(String token, Boolean isActorToken)     at Microsoft.SharePoint.IdentityModel.SPApplicationAuthenticationModule.TryExtractAndValidateToken(HttpContext httpContext, SPIncomingTokenContext& tokenContext) f7bc5552-0d29-d3ce-9f53-4adaaa44e728

    So, it is enough to start Refresh Trusted Security Token Services Metadata feed Timer Job manually.


    Friday, December 16, 2016 2:19 PM

All replies

  • Hi,

    It seems that the error message contains Correlation Id, please search the Correlation Id in ULS logs and provide error message (in English) here.

    ULS Viewer is a good tool to check the ULS logs:

    https://blogs.msdn.microsoft.com/opal/2009/12/22/uls-viewer-for-sharepoint-2010-troubleshooting/

    Please make sure that the User Profile Service is running correctly.

    A similar case for your reference:

    https://ramirezmery.wordpress.com/2015/04/01/sharepoint-2013-workflow-error-http-unauthorized-to-httpsitename_vti_binclient-svcweblistsgetbyid/

    Best Regards,

    Dean Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, December 16, 2016 2:14 AM
  • Thank you, I have found the solution.

    Here is a part of ULS Log:

    SPApplicationAuthenticationModule: Invalid token or signature. Exception: System.IdentityModel.Tokens.SecurityTokenException: Invalid JWT token. Could not resolve issuer token.     at Microsoft.IdentityModel.S2S.Tokens.JsonWebSecurityTokenHandler.ReadTokenCore(String token, Boolean isActorToken)     at Microsoft.IdentityModel.S2S.Tokens.JsonWebSecurityTokenHandler.ReadActor(IDictionary`2 payload)     at Microsoft.IdentityModel.S2S.Tokens.JsonWebSecurityTokenHandler.ReadTokenCore(String token, Boolean isActorToken)     at Microsoft.SharePoint.IdentityModel.SPApplicationAuthenticationModule.TryExtractAndValidateToken(HttpContext httpContext, SPIncomingTokenContext& tokenContext) f7bc5552-0d29-d3ce-9f53-4adaaa44e728

    So, it is enough to start Refresh Trusted Security Token Services Metadata feed Timer Job manually.


    Friday, December 16, 2016 2:19 PM