none
AutoSuggest: Searching for a Business Name vs an Address RRS feed

  • Question

  • Hi,

    I've noticed that when using the AutoSuggest module and searching by business name, it often results in a different (and inaccurate) point location than when searching by the address of the same business.

    You can use the Autosuggest UI sample in the Interactive SDK and add the "businessSuggestions: true" option, to replicate the example below (I can provide more examples if necessary).

    Search for "MacKenzie Corp" and you get the following (incorrect) location: 
    Mackenzie Corp, 10 Mauchly, Irvine, CA 92618, United States
    Lat: 33.6542510986328
    Lon: -117.751617431641

    Use the address instead (i.e. search for "10 Mauchly") and you get the correct location:
    Suggestion: 10 Mauchly, Irvine, California 92618, United States
    Lat: 33.652639
    Lon: -117.734177

    Is this a known limitation of using the businessSuggestion option?

    Thanks,

    Ken


    Tuesday, January 22, 2019 9:46 PM

Answers

  • Hi Ken,

    Thanks for the great details! As a result, the Bing Maps team has reproduced your issue and have accepted it as a high priority work item.  The issue is definitely related to name being included with the address and they agree with you that it is not specific to this one use case.

    The team does work on an Agile schedule so I can't commit to a timeline but the raised priority should help move the issue to the top of their queue.

    Sincerely,

    IoTGirl


    Wednesday, January 23, 2019 8:31 PM
    Owner

All replies

  • Hi Ken,

    Both addresses look the same to me.  Can you clarify what is incorrect?

    Note: To address your business listings, please reach out to https://www.bingplaces.com/

    Sincerely,

    IoTGirl

    Tuesday, January 22, 2019 10:17 PM
    Owner
  • Hi,

    Correct, both addresses are the same, however the lat/lons are very different.

    Ken

    Wednesday, January 23, 2019 12:09 AM
  • Hi Ken,

    1. I type the address given into Bing.com/maps

    a. I get the expected location 

    2. I type the given name MacKenzie Corp into Bing.com/maps

    a. I get another bubble at the same location

    I do see that the lat/lon pair you have for option 2 do not match the location but I don't know the steps you used to get those numbers.

    I am not trying to be difficult I just don't have the full details.  Please keep in mind that those of us on the forums do not have your computer in front of us so we do need all steps to see the issue and understand what is wrong.

    Sincerely,

    IoTGirl

    Wednesday, January 23, 2019 4:50 AM
    Owner
  • I'm using the AutoSuggest Module of the Bing Maps V8 API.

    To replicate the problem I'm referring to, you can use the Autosuggest UI sample from the Bing Maps Interactive SDK located here: https://www.bing.com/api/maps/sdk/mapcontrol/isdk/autosuggestui

    You must add the following to the code at line 8 in order test the results of business suggesstions:

    , businessSuggestions: true

    And then hit the "Run" button (i.e. green circle/white arrow) to make the change take effect.

    You can now type in "MacKenzie Corp", select the business suggestion indicated by a building icon in the dropdown, and you will see the results in the "Printout window" of the interface.

    If you then type in "10 Mauchly" (i.e. the address for the business) and select the address location indicated by a pushpin icon, you will get the same address information, but a different geocode (i.e. lat/lon) and pushpin location in the printout window

    I can provide more examples of this same behavior if necessary.

    Thanks,

    Ken
    Wednesday, January 23, 2019 4:37 PM
  • Hi Ken,

    Thanks for the great details! As a result, the Bing Maps team has reproduced your issue and have accepted it as a high priority work item.  The issue is definitely related to name being included with the address and they agree with you that it is not specific to this one use case.

    The team does work on an Agile schedule so I can't commit to a timeline but the raised priority should help move the issue to the top of their queue.

    Sincerely,

    IoTGirl


    Wednesday, January 23, 2019 8:31 PM
    Owner
  • Thank you for sticking with me!

    Ken

    Wednesday, January 23, 2019 8:36 PM
  • You are so very welcome! Thank you for being understanding about my repeated questions! :)
    Wednesday, January 23, 2019 8:40 PM
    Owner
  • Hi Ken,

    The team says this issue has now been fixed.  

    sincerely,

    IoTGirl

    Tuesday, February 25, 2020 6:39 PM
    Owner
  • Great news! Just tested several business names vs. addresses that were returning different geocodes and are now returning the same.

    Thank you!

    Ken

    Tuesday, February 25, 2020 6:46 PM