locked
Lab Environement System Connect Fails RRS feed

  • Question

  • Just getting started in setting up a standard environment on a pre-existing Windows 7 Client machine. I create the new environment, then add the machine, but when I click on connect I get this message:

    "Microsoft Environment Viewer could not connect to the machine xxxxx  Issue....More Information"  Clicking on more information ultimately brings me to this forum..

    So I ran a trace to see what's happening which is this:

    Step 1) The lab manager sends a post request to the LabService.asmx TFS server page sending a LABGUID as the guery.  Can't see the response as it is encrypted.

    Step 2) Then a post is sent out to the TFS service TestManagementWebService.asmx.  Followed by a query to find Test runs where state is "Inprogress" or "Waiting" and "IsAutomated"  and that's when we see the error.  Attempts to reconnect do the same thing.

    Now if I attempt to connect via RDP using the Microsoft Environment Viewer everything works perfect.  Addtionally when I first configured the environment and pressed Validate, everything validated correctly.  When it was created the Test Agent was downloaded automatically and I validated that the service was up and running!

    Any hints would be appreaciated.


    JP Cowboy Coders Unite!

    Friday, September 14, 2012 5:26 PM

Answers

  • Actually Trevor if it is beyond what can be done in the forums then there a gap somewhere because the answer was simple.

    The "Connect" option is for Virtual Machine environments and brings up a RDP session!  The Connect Via RDP is for both VM environments and "Standard" envrionments (emphasis on "Standard") because the "Connection" option only shows an error when attempting to open on a "Standard" configuration!

    Too bad MSFT support didn't know that or that it's only paid support.


    JP Cowboy Coders Unite!

    • Marked as answer by Mr. Javaman II Friday, September 21, 2012 11:42 AM
    Friday, September 21, 2012 11:42 AM

All replies

  • Hi Mr. Javaman II,

    I am trying to involve someone familiar with this topic to further look at this issue.

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Monday, September 17, 2012 6:53 AM
    Moderator
  • I read a bit futher on this subject.  I think I understand the connect option to be a part of what SCVVM does.  So in the lab environment that consists of only VM machines, the connect must bring up the list in a simlar manner to SCVVM.  But that is only a guess.

    If one uses a "Standard" environment it boils down to being a collection of "Real Machines" and ultimately is only just a RDP concentrator in that you can single click connect to any of the machines in that Lab Environment. 

    Please Advise.


    JP Cowboy Coders Unite!

    Tuesday, September 18, 2012 5:03 PM
  • From a support perspective this is really beyond what we can do here in the forums. This will require some 1:1 assistance, possibly over a Live Meeting connection.

    If you cannot determine your answer here or on your own, consider opening a support case with us. Visit this link to see the various support options that are available to better meet your needs:  http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone.


    Trevor Hancock (Microsoft)
    Please remember to "Mark As Answer" the replies that help.

    Wednesday, September 19, 2012 2:53 PM
  • Actually Trevor if it is beyond what can be done in the forums then there a gap somewhere because the answer was simple.

    The "Connect" option is for Virtual Machine environments and brings up a RDP session!  The Connect Via RDP is for both VM environments and "Standard" envrionments (emphasis on "Standard") because the "Connection" option only shows an error when attempting to open on a "Standard" configuration!

    Too bad MSFT support didn't know that or that it's only paid support.


    JP Cowboy Coders Unite!

    • Marked as answer by Mr. Javaman II Friday, September 21, 2012 11:42 AM
    Friday, September 21, 2012 11:42 AM