none
EDI Receive pipeline/party configuration RRS feed

  • Question

  •  

    I have a a file recieve location coming through an EDI pipeline, the file i am sending through is a txt file with multiple records in each document using the "~" as a delimiter. the error im receiving is posted below .the schema is the included X12 4010 810 schema in biztalk 2006 R2, the file doesnt validate with the schema but i think its because of the batched files. any insight would be very helpful.

     

    Error encountered: ERROR (62), interchangenr 10006 :

    The length of the element is not correct. Contact the sender.source format: [5 00401 ,X12-4010]

    source document: [(unknown)]

    source segment: [data#0,def#3,tag=GS ,name=Functional Group Header]

    source element: [def#3,elm#3,comp#0,tag=124,name=Application receivers code], value: [P], minimum length: [2] (msgnr:0 segnr:0)(line:1 pos:126 filepos:424)

     

    thanks,

     

      Kevin

    Tuesday, June 10, 2008 7:06 PM

Answers

  • Trailing white space is just that - trailing white space.  The fact that you managed to slip P with a space after it by the party settings in PAM does not change that fact.  Probably the BTS team should correct that by calling .Trim before validating the segment length entered in the UI.

     

    Take another look at your error:

     

    "source element: [def#3,elm#3,comp#0,tag=124,name=Application receivers code], value: [P], minimum length: [2] (msgnr:0 segnr:0)(line:1 pos:126 filepos:424)"

     

    Even though you put "P space" into the PAM, the Engine is seeing this entry as simply "P".  The trailing white space is not included in the value.  There is a setting to ignore leading and trailing zeroes and white spaces in PAM under the ACK Processing and Validation Settings, but setting this to true will not get those zeroes or white spaces to be part of a value - and you would not want it to either.

     

    Bottom line, you need at least two characters for the GS3 segment, and that should be set in the PAM under the GS and ST segments Settings tab.

     

    Friday, June 13, 2008 5:04 AM

All replies

  • Looks like input EDI document doesn't conform to Schema deployed. You are sending source element which doesn't conform to minimum length.

     

    "source element: [def#3,elm#3,comp#0,tag=124,name=Application receivers code], value: [P], minimum length: [2] (msgnr:0 segnr:0)(line:1 pos:126 filepos:424)"

     

     

    Wednesday, June 11, 2008 6:39 AM
  •  

    this is the document im attempting to validate to the schema (X12 4010 810)

     

    ISA~00~          ~00~          ~ZZ~XXX/CENTRAL2   ~ZZ~XXXXXEDI       ~080604~0716~X~00401~000001146~0~P~:+GS~IN~XXX/CENTRAL2~P ~20080604~0716~1145~X~004010+ST~810~0001+BIG~20080603~1110870~20080602~~86525~~DR+N1~ST~XXXXX XXXXXX  XXX.+FOB~DE~RT~XXX XXX TR~~~ZZ~PREPAID & ADDED+IT1~001~22~GA~51.52~RE~BP~UC105042~PO~407611-001~LT~51542+QTY~FL~1+CTP~~EUP~113344+PID~F~~ZZ~DRUM~DURANAR SADDLE BROWN+TDS~11334400+AMT~ZZ~220+SE~11~0001+

     

    When i try to validate it this is the only error i get

    error BEC2004: Validate Instance : Failed to validate instance

    Wednesday, June 11, 2008 2:34 PM
  • GS3 has min length of 2, and all you have in there is "P".

    JT

     

    Wednesday, June 11, 2008 4:16 PM
  • Actually it is a P followed by a space, in the party settings for the EDI receiver i can make the G3 be a P followed by a space and it accepts that as 2 characters, but for some reason when its reading the EDI its ignoring whitespace. is there a way to disable that?

     

    And if i change the GS3 to PP, it accepts it but it gets this error:

    Error encountered: ERROR (41), interchangenr 10027 :

    The sender of the document is not recognized. Contact the system administrator.sender:

    [][] [XXX/CENTRAL2][ZZ][XXX/CENTRAL2],  (msgnr:0 segnr:0)(line:1 pos:151 filepos:449)sender: [][] [XXX/CENTRAL2][ZZ][XXX/CENTRAL2]sender: [][] [XXX/CENTRAL2][ZZ][XXX/CENTRAL2]
    sender: [][] [XXX/CENTRAL2][ZZ][XXX/CENTRAL2]sender: [][] [XXX/CENTRAL2][ZZ][XXX/CENTRAL2]
    sender: [][] [XXX/CENTRAL2][ZZ][XXX/CENTRAL2]sender: [][] [XXX/CENTRAL2][ZZ][XXX/CENTRAL2]
    sender: [][] [XXX/CENTRAL2][ZZ][XXX/CENTRAL2]sender: [][] [XXX/CENTRAL2][ZZ][XXX/CENTRAL2]
    sender: [][] [XXX/CENTRAL2][ZZ][XXX/CENTRAL2]recipient: [][] [OOOEDI][ZZ][PP]
    recipient: [][] [OOOEDI][ZZ][PP]
    source format: [5 00401 ,X12-4010]
    source document: [unknown]
    source segment: [data#0,def#0,tag=GS   ,name=unknown]

     

     

    im guessing its a setting in the party. but what should go where?

     

    Thursday, June 12, 2008 2:06 PM
  • Trailing white space is just that - trailing white space.  The fact that you managed to slip P with a space after it by the party settings in PAM does not change that fact.  Probably the BTS team should correct that by calling .Trim before validating the segment length entered in the UI.

     

    Take another look at your error:

     

    "source element: [def#3,elm#3,comp#0,tag=124,name=Application receivers code], value: [P], minimum length: [2] (msgnr:0 segnr:0)(line:1 pos:126 filepos:424)"

     

    Even though you put "P space" into the PAM, the Engine is seeing this entry as simply "P".  The trailing white space is not included in the value.  There is a setting to ignore leading and trailing zeroes and white spaces in PAM under the ACK Processing and Validation Settings, but setting this to true will not get those zeroes or white spaces to be part of a value - and you would not want it to either.

     

    Bottom line, you need at least two characters for the GS3 segment, and that should be set in the PAM under the GS and ST segments Settings tab.

     

    Friday, June 13, 2008 5:04 AM
  • Thanks for the response John!

     

    I found the setting under the ACK Processing and Validation Settings and you were right about it not accepting the white space as a character. But as far as the GS and ST segment settings, it still confuses me why it will accept a "P " as two characters but then not recognize it from the file.

     

    Could this possibly be a change from 2002 to 2006? the file that only has a "P" for this entry works file in BT2002.

     

    Say i get the file changed, im still getting the error about not recognizing the sender... in the party settings -- ISA Segment Definition, i have the sender identifier set as "XXX/CENTRAL2" and the receiver identifier set as "OOOEDI". Any idea why im still getting the error in my previous post?

     

    Thanks for all your help,

      Kevin

     

    Friday, June 13, 2008 12:17 PM
  • So i rechecked, and that setting was checked in my configuration from when i was trouble shooting another error earlier. when i unchecked it, i no longer got the error about the unrecognized sender. thanks!

     

    Friday, June 13, 2008 3:54 PM