locked
Always On Connectivity RRS feed

  • Question

  • Hi,

    I have configured always on in my environment.

    Both the servers are in same datacenter and under same cloud service.

    It is set up as synchronous commit.

    I'm able to connect to always-on listener through active node but unable to connect through passive node.

    Please let me know how can i connect to the listener through passive node.

    Thanks,

    Har

    Friday, July 3, 2015 3:37 PM

Answers

  • use a specific registered ip address for your listner.

    Make sure you configured using this ip address. 

    make a note if you connect through listner that means you always connect tot he primary node not the secondary replica. you can not connect to the second replica using active listner connection.

    if you wanted to connect tot he secndary replica use machine name or other means. YOur replica must be configure to read only or read\write...

    Thursday, July 16, 2015 5:52 AM

All replies

  • haka1

    There’s no such thing as a passive node in Availability Groups. Is there fail-over happened? Pleas explain what you are doing in details, what errors are you getting?


    Best Regards,Uri Dimant SQL Server MVP, http://sqlblog.com/blogs/uri_dimant/

    MS SQL optimization: MS SQL Development and Optimization
    MS SQL Consulting: Large scale of database and data cleansing
    Remote DBA Services: Improves MS SQL Database Performance
    SQL Server Integration Services: Business Intelligence

    Saturday, July 4, 2015 8:04 AM
  • Hi,

    I have configured always on in my environment.

    Both the servers are in same datacenter and under same cloud service.

    It is set up as synchronous commit.

    I'm able to connect to always-on listener through active node but unable to connect through passive node.

    Please let me know how can i connect to the listener through passive node.

    Thanks,

    Har

    Please share the error messages and screens, There is no passive node concept on this always on.

    Regards, Pradyothana DP. Please Mark This As Helpful if it helps to solve your issue. ========================================================== https://social.technet.microsoft.com/Profile/pradyothanadp http://www.dbainhouse.blogspot.in/

    Saturday, July 4, 2015 9:09 AM
  • You need tell us whether you getting error message. If you are not getting any error message , you need to use APPLICATION INTENT as "READ ONLY" which will connective to passive node.

    -kccrga http://dbatrend.blogspot.com.au/

    • Proposed as answer by kccrga Wednesday, July 22, 2015 3:24 AM
    • Unproposed as answer by kccrga Wednesday, July 22, 2015 3:24 AM
    Thursday, July 16, 2015 5:21 AM
  • use a specific registered ip address for your listner.

    Make sure you configured using this ip address. 

    make a note if you connect through listner that means you always connect tot he primary node not the secondary replica. you can not connect to the second replica using active listner connection.

    if you wanted to connect tot he secndary replica use machine name or other means. YOur replica must be configure to read only or read\write...

    Thursday, July 16, 2015 5:52 AM