locked
ERROR_INTERNET_INVALID_CA error RRS feed

  • Question

  • Hello,

    I'm working on WM5 PPC\SP and i get this error (ERROR_INTERNET_INVALID_CA) when i try to use HttpSendRequest API.
    I have to add that on WM6 it doesn't happen and i added to the HttpOpenRequest all the following flags:
    connFlags = INTERNET_FLAG_KEEP_CONNECTION | INTERNET_FLAG_SECURE | INTERNET_FLAG_IGNORE_CERT_CN_INVALID
    | INTERNET_FLAG_IGNORE_CERT_DATE_INVALID | SECURITY_FLAG_IGNORE_UNKNOWN_CA
    | INTERNET_FLAG_NO_AUTO_REDIRECT | INTERNET_FLAG_IGNORE_REDIRECT_TO_HTTPS
    | INTERNET_FLAG_NO_AUTH | INTERNET_FLAG_IGNORE_REDIRECT_TO_HTTP | SECURITY_FLAG_IGNORE_REVOCATION;
    But i would like to avoid involving the user in this process.
    Does anyone have an idea how to solve it?
    Thanks.
    Monday, January 11, 2010 12:30 PM

Answers

  • The following KB article will show you two ways of handling the ERROR_INTERNET_INVALID_CA error - using InternetErrorDlg to get user's permission or setting the SECURITY_FLAG_IGNORE_UNKNOWN_CA option.

    How To Handle Invalid Certificate Authority Error with WinInet
    http://support.microsoft.com/kb/182888  

    If you have further questions, please don't forget to post the complete code.



    Please mark the post that helps you, and unmark that does not. This benefits our community.
    • Marked as answer by warrentang Friday, January 15, 2010 2:10 AM
    Wednesday, January 13, 2010 8:11 AM

All replies

  • The following KB article will show you two ways of handling the ERROR_INTERNET_INVALID_CA error - using InternetErrorDlg to get user's permission or setting the SECURITY_FLAG_IGNORE_UNKNOWN_CA option.

    How To Handle Invalid Certificate Authority Error with WinInet
    http://support.microsoft.com/kb/182888  

    If you have further questions, please don't forget to post the complete code.



    Please mark the post that helps you, and unmark that does not. This benefits our community.
    • Marked as answer by warrentang Friday, January 15, 2010 2:10 AM
    Wednesday, January 13, 2010 8:11 AM
  • Hi,

    Thanks, i'll try it and update you.
    Wednesday, January 13, 2010 1:52 PM