locked
SQL 2008 R2 Developer Reporting Services Install fail RRS feed

  • Question

  • I have been trying for about a week and chasing all the leads i can through here to get Reporting Services to install on my pc.  It seems to always fail and point to the Native Client installation media not being correct.  So digging deeper into the logs I find where we're getting this error "Install_sql_rs_Cpu32_Action" failed during execution."

    Operating System: Windows XP Pro sp3

    Below is a partial of my log file

    2011-09-20 09:55:22 Slp: Sco: Attempting to write hklm registry key SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall to file C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20110920_095116\Registry_SOFTWARE_Microsoft_Windows_CurrentVersion_Uninstall.reg_
    2011-09-20 09:55:22 Slp: Sco: Attempting to write hklm registry key SOFTWARE\Microsoft\MSSQLServer to file C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20110920_095116\Registry_SOFTWARE_Microsoft_MSSQLServer.reg_
    2011-09-20 09:55:23 Slp:
    2011-09-20 09:55:23 Slp: Watson bucket for Msi based failure has been created
    2011-09-20 09:55:23 Slp: No retry-able MSI return code detected.
    2011-09-20 09:55:23 Slp: Checkpoint: INSTALL_SQL_RS_CPU32_ACTION
    2011-09-20 09:55:23 Slp: Error: Action "Install_sql_rs_Cpu32_Action" failed during execution.
    2011-09-20 09:55:23 Slp: Completed Action: Install_sql_rs_Cpu32_Action, returned False
    2011-09-20 09:55:24 Slp: Action "Install_sql_rs_loc_Cpu32_1033_Action" will return false due to the following conditions:
    2011-09-20 09:55:24 Slp: Condition "Validate feature dependencies for package: sql_rs_loc_Cpu32_1033. The condition ensures that at least one of the features to be changed has its dependencies satisified." did not pass as it returned false and true was expected.
    2011-09-20 09:55:24 Slp: Checking the state of all features the package depends on.
    2011-09-20 09:55:24 Slp: Condition "Feature dependency condition for action: Install_sql_rs_loc_Cpu32_1033_Action The condition tests feature: RS_Server_Adv_Loc_sql_rs_loc_Cpu32_1033. There are 3 dependant features. The feature is tested for results: ValidateResult, Result." did not pass as it returned false and true was expected.
    2011-09-20 09:55:24 Slp: Condition is false because the required feature RS_Server_Adv_sql_rs_Cpu32 failed in result Result
    2011-09-20 09:55:24 Slp: Condition "Feature dependency condition for action: Install_sql_rs_loc_Cpu32_1033_Action The condition tests feature: RS_Web_Interface_Adv_Loc_sql_rs_loc_Cpu32_1033. There are 2 dependant features. The feature is tested for results: ValidateResult, Result." did not pass as it returned false and true was expected.
    2011-09-20 09:55:24 Slp: Condition is false because the required feature RS_Server_Adv_Loc_sql_rs_loc_Cpu32_1033 failed in result Result

    I have the full log if someone wants to see it but I dont see how to upload it

    Schott

     

    Tuesday, September 20, 2011 2:43 PM

Answers

  • Hi ,

    After looking through the log file 'detail.txt ', I found the trace. The root cause is about version :

    2011-09-20 10:17:41 Slp: Package ID sql_engine_core_inst_loc_ctp6_Cpu32_1033: Discovery: Package version data are " Installed Version: 10.50.1600.1 MinVersion: 10.0.1400 MaxVersion: 10.50.1599.1"
    2011-09-20 10:17:41 Slp: Package ID sql_engine_core_inst_loc_ctp6_Cpu32_1033: match result for Discovery - Version: False, Cpu: True, Language: True
    2011-09-20 10:17:41 Slp: Package ID sql_engine_core_inst_loc_ctp6_Cpu32_1033: NotInstalled - Package was found but determined as NotInstalled because at least one of CPU,

    You need to apply for the latest CU/CP and install again.

     

     


    Best Regards,
    Peja

    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Edited by Peja Tao Tuesday, September 27, 2011 2:54 AM
    • Proposed as answer by Peja Tao Tuesday, September 27, 2011 2:54 AM
    • Marked as answer by Peja Tao Thursday, October 6, 2011 9:05 AM
    Tuesday, September 27, 2011 2:53 AM

All replies

  • Hi Schott,

    Could you please detailed version of the SQL Server you installed?

    Below is the way to get the three log files which you could share with us:
    1)  You could find the summary.txt at your folder C:\ProgramFiles\Microsoft SQL Server\100\Setup Bootstrap\Log\  . And you need to open summary.txt, and then you can generally search for “error” or “failed” keywords.
    2)  For more information about details of the failure, open the file that is listed in the line starting with “Log with failure” in summary.txt. You could see file named like Summary_<%ComputerName%_YYYYMMDD_HHMMSS>.txt which could be found in C:\ProgramFiles\Microsoft SQL Server\100\Setup Bootstrap\Log\<YYYYMMDD_HHMMSS>\Summary_<%ComputerName%_YYYYMMDD_HHMM>.txt
    3) To find errors in this file, you can generally search for “error” or “failed” keywords in Summary_<%ComputerName%_YYYYMMDD_HHMM>.txt. For more information about details of the failure, open the file that is listed in the line starting with “Log with failure”.  That file is named like Detail.txt which located in c:\ProgramFiles\Microsoft SQL Server\100\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\Detail.txt

    If the log files are too large to post, you could put them in a shared network folder like 'Skydriver'.

    Hope this helps,


    Best Regards,
    Peja

    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Edited by Peja Tao Wednesday, September 21, 2011 5:47 AM
    Wednesday, September 21, 2011 5:42 AM
  • I've added the logs to skydrive in my public folder in a zip file.  Not sue how to let you know where in the skydrive they are, but they are there

    My OS is Windows XP Pro 32 bit, the SQL I am loading is SQL2008 R2 developer

    https://skydrive.live.com/#!/?cid=F731AC581EB7B633&id=F731AC581EB7B633%21108!cid=F731AC581EB7B633&id=F731AC581EB7B633%21140


    Heres where it is failing in the log

    2011-09-20 10:18:36 Slp: ----------------------------------------------------------------------

    2011-09-20 10:18:36 Slp: Running Action: MsiTimingAction

    2011-09-20 10:18:36 Slp: ----------------------------------------------------------------------

    2011-09-20 10:18:36 Slp: Running Action: Install_sql_rs_Cpu32_Action

    2011-09-20 10:18:36 Slp: Sco: Attempting to create base registry key HKEY_LOCAL_MACHINE, machine

    2011-09-20 10:18:36 Slp: Sco: Attempting to open registry subkey

    2011-09-20 10:18:36 Slp: Sco: Attempting to open registry subkey SOFTWARE\Microsoft\VisualStudio\9.0

    2011-09-20 10:18:36 Slp: Sco: Attempting to get registry value InstallDir

    2011-09-20 10:18:36 Slp: Target package: "D:\x86\setup\sql_rs.msi"

    2011-09-20 10:18:36 Slp: InstallPackage: MsiInstallProduct returned the result code 1639.

    2011-09-20 10:18:36 Slp: Watson Bucket 1

     

    The 1639 error relates to a invalid command line argument, this installation is being run via the install, there are no command line args

    • Edited by WritinCode Wednesday, September 21, 2011 8:36 PM
    Wednesday, September 21, 2011 4:12 PM
  • Hi ,

    After looking through the log file 'detail.txt ', I found the trace. The root cause is about version :

    2011-09-20 10:17:41 Slp: Package ID sql_engine_core_inst_loc_ctp6_Cpu32_1033: Discovery: Package version data are " Installed Version: 10.50.1600.1 MinVersion: 10.0.1400 MaxVersion: 10.50.1599.1"
    2011-09-20 10:17:41 Slp: Package ID sql_engine_core_inst_loc_ctp6_Cpu32_1033: match result for Discovery - Version: False, Cpu: True, Language: True
    2011-09-20 10:17:41 Slp: Package ID sql_engine_core_inst_loc_ctp6_Cpu32_1033: NotInstalled - Package was found but determined as NotInstalled because at least one of CPU,

    You need to apply for the latest CU/CP and install again.

     

     


    Best Regards,
    Peja

    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Edited by Peja Tao Tuesday, September 27, 2011 2:54 AM
    • Proposed as answer by Peja Tao Tuesday, September 27, 2011 2:54 AM
    • Marked as answer by Peja Tao Thursday, October 6, 2011 9:05 AM
    Tuesday, September 27, 2011 2:53 AM