locked
Excel Services: First time opening an excel file gives error RRS feed

  • Question

  • Hi all,

    When we open any excel file for the first time that day, we have the error:

    "Unable to process the request. Wait a few minutes and try performing this operation again."

    When we wait a few minutes, the excel file, and any other excel file in the same web application, opens without a problem. Excel files in other web applications still have the error until they also wait a few minutes after their first attempt of the day.

    In the ULS-logs I find this message:

    Result=Microsoft.Office.Excel.Server.CalculationServer.Proxy.ServerSession+RetryException: RetryException ---> Microsoft.Office.Excel.Server.CalculationServer.Proxy.ServerSessionException: Unable to process the request. ---> System.Net.WebException: The remote server returned an error: (503) Server Unavailable.    
     at System.Net.HttpWebRequest.GetResponse()    
     at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout)     -
     -- End of inner exception stack trace ---     -
     -- End of inner exception stack trace ---    
     at Microsoft.Office.Excel.Server.CalculationServer.Proxy.ServerSession.ExecuteWebMethodCore(WebMethodType webMethodType, WebMethodBehaviorAttribute webMethodBehavior, CommandParameter parameter, CoreWebMethod coreWebMe


    Is there anyone who had the same problem and managed to solve this problem? Should we consider some sort of Wake-up script?

    Any help would be appreciated. 

    Kind regards,
    Frederik

    Thursday, September 10, 2015 7:05 AM

Answers

  • Hi,

    From the error message, I searched form the internet, the issue may be resulted form that the web site used for the SharePoint Web Services had the ASP.NET Impersonation Authentication method enabled.

    Try to disable the ASP.NET Impersonation again.

    Open up the  IIS Manager on the SharePoint server

    1. Expand “Sites”.
    2. Expand  “SharePoint Web Services” and select “Excel Services Application”(you can choose Excel  Services Application from the id: CA->Application Management->Manage service application->Click Excel Services Service  Application->you can find the id from the URL).
    3. Double click on “Authentication”(under IIS).
    4. Disable ASP.NET impersonation.
    5. IISRESET.

    For more detailed information, refer to the following article:

    http://www.stefanjohansson.org/2013/03/excel-services-unable-to-process-the-request-wait-a-few-minutes-and-try-performing-this-operation-again/

    Besides, here is a similar issue article, you can take a look at:

    http://sharepointfarmer.com/excel-services-is-unable-to-process-the-request-wait-a-few-minutes-and-try-performing-this-operation-again/

    Best Regards

    Lisa Chen


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, September 11, 2015 7:27 AM
  • Hi all,

    When we open any excel file for the first time that day, we have the error:

    "Unable to process the request. Wait a few minutes and try performing this operation again."

    When we wait a few minutes, the excel file, and any other excel file in the same web application, opens without a problem. Excel files in other web applications still have the error until they also wait a few minutes after their first attempt of the day.

    In the ULS-logs I find this message:

    Result=Microsoft.Office.Excel.Server.CalculationServer.Proxy.ServerSession+RetryException: RetryException ---> Microsoft.Office.Excel.Server.CalculationServer.Proxy.ServerSessionException: Unable to process the request. ---> System.Net.WebException: The remote server returned an error: (503) Server Unavailable.    
     at System.Net.HttpWebRequest.GetResponse()    
     at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout)     -
     -- End of inner exception stack trace ---     -
     -- End of inner exception stack trace ---    
     at Microsoft.Office.Excel.Server.CalculationServer.Proxy.ServerSession.ExecuteWebMethodCore(WebMethodType webMethodType, WebMethodBehaviorAttribute webMethodBehavior, CommandParameter parameter, CoreWebMethod coreWebMe


    Is there anyone who had the same problem and managed to solve this problem? Should we consider some sort of Wake-up script?

    Any help would be appreciated. 

    Kind regards,
    Frederik

    Sounds exactly like you describe. That application pool takes too long to render, hence giving a "server not available.".

    Generally you should always consider a warm up script.

    Here is an example of an extremely simple wake up, which should be easy to expand, also to clicking Excel documents :)

    https://jesperarnecke.wordpress.com/2014/03/07/warmup-script-sharepoint/

    Friday, September 11, 2015 7:42 AM

All replies

  • Hi,

    From the error message, I searched form the internet, the issue may be resulted form that the web site used for the SharePoint Web Services had the ASP.NET Impersonation Authentication method enabled.

    Try to disable the ASP.NET Impersonation again.

    Open up the  IIS Manager on the SharePoint server

    1. Expand “Sites”.
    2. Expand  “SharePoint Web Services” and select “Excel Services Application”(you can choose Excel  Services Application from the id: CA->Application Management->Manage service application->Click Excel Services Service  Application->you can find the id from the URL).
    3. Double click on “Authentication”(under IIS).
    4. Disable ASP.NET impersonation.
    5. IISRESET.

    For more detailed information, refer to the following article:

    http://www.stefanjohansson.org/2013/03/excel-services-unable-to-process-the-request-wait-a-few-minutes-and-try-performing-this-operation-again/

    Besides, here is a similar issue article, you can take a look at:

    http://sharepointfarmer.com/excel-services-is-unable-to-process-the-request-wait-a-few-minutes-and-try-performing-this-operation-again/

    Best Regards

    Lisa Chen


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, September 11, 2015 7:27 AM
  • Hi all,

    When we open any excel file for the first time that day, we have the error:

    "Unable to process the request. Wait a few minutes and try performing this operation again."

    When we wait a few minutes, the excel file, and any other excel file in the same web application, opens without a problem. Excel files in other web applications still have the error until they also wait a few minutes after their first attempt of the day.

    In the ULS-logs I find this message:

    Result=Microsoft.Office.Excel.Server.CalculationServer.Proxy.ServerSession+RetryException: RetryException ---> Microsoft.Office.Excel.Server.CalculationServer.Proxy.ServerSessionException: Unable to process the request. ---> System.Net.WebException: The remote server returned an error: (503) Server Unavailable.    
     at System.Net.HttpWebRequest.GetResponse()    
     at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout)     -
     -- End of inner exception stack trace ---     -
     -- End of inner exception stack trace ---    
     at Microsoft.Office.Excel.Server.CalculationServer.Proxy.ServerSession.ExecuteWebMethodCore(WebMethodType webMethodType, WebMethodBehaviorAttribute webMethodBehavior, CommandParameter parameter, CoreWebMethod coreWebMe


    Is there anyone who had the same problem and managed to solve this problem? Should we consider some sort of Wake-up script?

    Any help would be appreciated. 

    Kind regards,
    Frederik

    Sounds exactly like you describe. That application pool takes too long to render, hence giving a "server not available.".

    Generally you should always consider a warm up script.

    Here is an example of an extremely simple wake up, which should be easy to expand, also to clicking Excel documents :)

    https://jesperarnecke.wordpress.com/2014/03/07/warmup-script-sharepoint/

    Friday, September 11, 2015 7:42 AM
  • Hi Jesper,

    Thank you for your reply. I was busy with other things, so didn't had the time yet to test this out.

    When I run your script, it seems to work. But when I try to run your script via a sheduled task, it stays on running. Has it something to with the fact that the script uses an instance of IE?

    Kind regards,

    Frederik

    Wednesday, October 28, 2015 10:39 AM
  • Hi,

    From the error message, I searched form the internet, the issue may be resulted form that the web site used for the SharePoint Web Services had the ASP.NET Impersonation Authentication method enabled.

    Try to disable the ASP.NET Impersonation again.

    Open up the  IIS Manager on the SharePoint server

    1. Expand “Sites”.
    2. Expand  “SharePoint Web Services” and select “Excel Services Application”(you can choose Excel  Services Application from the id: CA->Application Management->Manage service application->Click Excel Services Service  Application->you can find the id from the URL).
    3. Double click on “Authentication”(under IIS).
    4. Disable ASP.NET impersonation.
    5. IISRESET.

    For more detailed information, refer to the following article:

    http://www.stefanjohansson.org/2013/03/excel-services-unable-to-process-the-request-wait-a-few-minutes-and-try-performing-this-operation-again/

    Besides, here is a similar issue article, you can take a look at:

    http://sharepointfarmer.com/excel-services-is-unable-to-process-the-request-wait-a-few-minutes-and-try-performing-this-operation-again/

    Best Regards

    Lisa Chen


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thx for your reply Lisa. I checked, but the ASP.NET impersonation was disabled on all the sharepoint servers in the farm.
    Wednesday, October 28, 2015 10:49 AM
  • Hi Frederik,

    Just go to your Central Admin site --> Manage web App --> Highlight the web app --> Click on Service Connections from the Ribbon

    make sure that you selected "Excel Services Application" and click Ok

    Thanks

    • Proposed as answer by Taifour Wednesday, October 28, 2015 11:24 AM
    • Unproposed as answer by Taifour Sunday, November 1, 2015 7:52 AM
    Wednesday, October 28, 2015 11:24 AM
  • Hi Frederik,

    Just go to your Central Admin site --> Manage web App --> Highlight the web app --> Click on Service Connections from the Ribbon

    make sure that you selected "Excel Services Application" and click Ok

    Thanks

    Hi Taifour,

    I checked this and Excel Services Application was selected.

    Just to be clear. I only get this error when I try to open an excel file for the first time of the day. After a few minutes, everything works fine.

    Wednesday, October 28, 2015 12:15 PM
  • Hi Frederik,

    Do you mind share the Log file part when the issue happens? and is your environment connected to the Internet or not? do you have 2 environment one UAT and one for Prod? if yes is it working on the UAT and Prod not?

    Thanks. 

    Sunday, November 1, 2015 4:52 AM