locked
Error with Microsoft Excel Connecting to SQL Server DataSource RRS feed

  • Question

  • Within Microsoft Excel when I tried connect to the SQL Server Database,  I get this error:

    Runtime Error : 1004

    Microsoft SQL:  A connection was successfully established with the server, but then an error occurred during the login process.

    SSL Provider - The Certificate Chain was issued by an authority that is not trusted.

    How do I fix this?? Please help.

    Thursday, May 7, 2020 7:06 PM

Answers

  • It doesn't give an option to select  TrustServerCertificate=True

    It do, just open the connection property, change to tab "Definition" and add the string to the connection string.

    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Friday, May 8, 2020 6:55 AM
  • Looks like you don't have CA certificate installed on your SQL Server. Please add additional parameter in your connection string. 

    TrustServerCertificate=True


    http://uk.linkedin.com/in/ramjaddu

    Thursday, May 7, 2020 7:52 PM

All replies

  • Looks like you don't have CA certificate installed on your SQL Server. Please add additional parameter in your connection string. 

    TrustServerCertificate=True


    http://uk.linkedin.com/in/ramjaddu

    Thursday, May 7, 2020 7:52 PM
  • But within MS Excel, I'm just using the Connection Wizard to make the connection to the SQL Server.

    It doesn't give an option to select  TrustServerCertificate=True

    How do I do this within Excel?

    Thursday, May 7, 2020 10:23 PM
  • Hi Veena Srinivas,

    >>SSL Provider - The Certificate Chain was issued by an authority that is not trusted.

    I suggest you install a certificate on your server, please follow the steps from Install a certificate on a server with Microsoft Management Console (MMC).

    Best regards,
    Cathy 


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com




    Friday, May 8, 2020 3:20 AM
  • It doesn't give an option to select  TrustServerCertificate=True

    It do, just open the connection property, change to tab "Definition" and add the string to the connection string.

    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Friday, May 8, 2020 6:55 AM
  • Hi Olaf,

    I tried to modify the connection string in the definition tab but it is greyed out.  Doesn't allow.

    Can I fix the error on the server side if I cannot fix from Excel?

    Friday, May 8, 2020 3:06 PM
  • It should be done on Excel end - 

    1. In Excel, on the Data tab, in Get External Data, click From Other Sources.

    2. Select From Analysis Services.

    3.  Add TrustServerCertificate=True to the existing connection


    http://uk.linkedin.com/in/ramjaddu

    Saturday, May 9, 2020 11:38 PM
  • I found a workaround,  for some reason it was not working with a Server Alias name, but I tried the actual server name and it worked.   I wonder why?


    Monday, May 11, 2020 7:03 PM