locked
WACK failed at Performance test

    Question

  • OS Version:
    Microsoft Windows 8 Pro (6.2.9200.0)
    Kit Version:
    2.2

    My app Failed at

    Performance test
    PASSED
    Bytecode generation
    PASSED
    Optimized Binding References
    PASSED
    Performance launch
    FAILED
    Performance suspend
    • Error Found: The performance suspend test collected the following results:
      • Application Error: Application Suspend was not detected for application App. This could be because your application failed to suspend correctly. Please consider re-running the test avoid interacting with the application while tests are running.
    • Impact if not fixed: Application suspend time is important for creating a fast and fluid experience for the user. This app will not be accepted by the Windows Store.
    • How to fix: The app received a failing score. You should ensure that your app’s performance is consistent across different machine configurations. The informational metrics can provide insight into area that could help improve your app’s performance, but do not impact your apps acceptance by the Windows Store. See link below for more information:
      Performance Best Practices

    I don't know how to fix.

    My app is a Music Player and using XAPO2 to playing music Background. I added Background Task Music in Package.appxmanifest

    • Moved by Roberts_E Thursday, September 26, 2013 2:55 PM moderation
    Monday, September 9, 2013 1:57 PM

Answers

  • Hi Raymond,

    Normally the app must launch in 5 seconds or less and must suspend in 2 seconds or less, otherwise it will fail for test. I think you could follow the Performance Best Practices WACK provide to you to validate what's happening during the suspend, or maybe you could share your suspend code with us for analysis.

    And another suggestion is you could run WACK on another machine to see if the app is still fail.

    Best Regards,

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Monday, September 30, 2013 7:23 AM
    Moderator

All replies

  • No one can't help me ? :(
    Friday, September 27, 2013 5:46 AM
  • Hi Raymond,

    Normally the app must launch in 5 seconds or less and must suspend in 2 seconds or less, otherwise it will fail for test. I think you could follow the Performance Best Practices WACK provide to you to validate what's happening during the suspend, or maybe you could share your suspend code with us for analysis.

    And another suggestion is you could run WACK on another machine to see if the app is still fail.

    Best Regards,

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Monday, September 30, 2013 7:23 AM
    Moderator