locked
Exception thrown on startup RRS feed

  • Question

  • Upon starting Blend 4 using SketchFlow, I immediately receive the following error with a stack trace:

    "Exception Error HRESULT E_FAIL has been returned from a call to a COM component"

    Stack Trace

    at MS.Internal.XcpImports.CheckHResult(UInt32 hr)

    at MS.Internal.XcpImports.FrameworkElement_MeasureOverride(FrameworkElement element, Size availableSize)

    at System.Windows.FrameworkElement.MeasureOverride(Size availableSize)

    at System.Windows.FrameworkElement.MeasureOverride(IntPtr nativeTarget, Single inWidth, SingleinHeight, Single& outWidth, Single& outHeight)...

    ____________________

    Another anomoly which may not be related:

    When I try to add a GridLine on the Artboard, it appears only while the mouse button is pressed, is not visible afterwards, and no grid division appears (no additional locks). Interestingly the Edit Menu will then show an item to "Undo Add Gridline"

     

     

    Tuesday, September 21, 2010 2:11 AM

All replies

  • Can you give us some specs of the system that you are running on? Have you tried uninstalling all previous versions and reinstalling Blend 4 as administrator? 
    My .NET Blog: http://michaelcrump.net
    Tuesday, September 21, 2010 2:18 PM
  • My hardware is an HP Precision M70 Laptop.

    I am using Windows XP Professional Ver 5.1 and had recently downloaded the free trial of Expression Ultimate 4 (with no previous version).

    At your suggestion, I just did a reinstall/repair, and the symptoms are the same. Do I need to fully uninstall and start over?

     

    Tuesday, September 21, 2010 8:06 PM
  • Here is an update.

    Another symptom in the problem project is that when I draw any object by click and drag, it appears above and to the left of the canvas not at the cursor postion. Also the default size for assets such as buttons shows as zero pixels and has to be resized manually.

    After reinstalling Expression, I started over with a new project and it appears to work okay. Thus it appears that the problems are associated with a corrupted project. Are there project specific files that can effect the graphics behavior of Blend 4?

     

     

    Wednesday, September 22, 2010 4:35 PM