locked
SSIS pakage hangs when updating to oracle RRS feed

  • Question

  • I am trying to update 10 rows to oracle 10g using OleDB Command,the dataflow task hangs on BIDS. This is on 64 bit Windows server 2008.

    No luck when tried running it on SQL Agent. I am using ODP connection to update the records.

    These are the components I have in the dataflow task. It is really simple. I am just trying to update one field for 10 rows.

    Source: ADO.NET Source ( Green)

    Transformation: Derived column ( Green )

    Transformation: Data Conversion ( yellow ) hangs

    Transformation: OLE DB Command ( yellow) hangs.

    Thanks in advance..


    Developer

    Wednesday, February 8, 2012 8:12 PM

Answers

All replies

  • It probably does not like the conversion. If I remember correctly, switch to ODBC and it must work.

    Arthur My Blog

    • Proposed as answer by Eileen Zhao Thursday, February 9, 2012 8:53 AM
    Wednesday, February 8, 2012 9:00 PM
  • Thanks for the reply,

    I figured it out.

    I ran an update on oracle in sql developer but didn't commit.

    When I try to update the same record(s) in SSIS, it just hangs.

    Tried three isolation levels "Read uncommitted", "Read Committed", "Serializable", still hangs.

    This may not happen in production scenario though.


    Developer

    • Marked as answer by Eileen Zhao Tuesday, February 21, 2012 7:32 AM
    • Unmarked as answer by Eileen Zhao Tuesday, February 21, 2012 7:32 AM
    Thursday, February 9, 2012 4:25 PM
  • Hi balne_raj,

    Please refer to the following artcile about troubleshooting SSIS package hanged for running:

    http://social.msdn.microsoft.com/Forums/en/sqlintegrationservices/thread/2cb0bec7-0fe2-4b8d-b59e-9534388c72e7 

    Thanks,
    Eileen
    • Marked as answer by Eileen Zhao Friday, May 4, 2012 12:28 AM
    Wednesday, February 22, 2012 9:08 AM