The following forum(s) have migrated to Microsoft Q&A (Preview): Developing Universal Windows apps!
Visit Microsoft Q&A (Preview) to post new questions.

Learn More

 locked
[UWP] IAP disappearing after app update RRS feed

  • Question

  • Hello,

    Yesterday I just released an update with an really small UI change. Now I get a lot of consumer who are complaining that their IAP (Ad free versions) are not there anymore. I dind't change the validating code for checking the IAP purchase, still suddenly this problems occur. When the user try to buy the IAP again, the operating system ist telling him that he has already bought it - which makes sense. Still it looks like app is becoming wrong licenceinformations now. The is app NOT beta.

    Anyone has experienced the same or does know solutions?

    With best regards

    Tim

    Thursday, December 17, 2015 2:09 PM

All replies

  • Hello,

    If we only do the update with an small UI change, it should not affect the IAP, since I do have all your code, it will be hard to tell something, I will recommend you use your developer account to open a support case by visiting this URL http://aka.ms/storesupport. You will get 1:1 support on that. Besides, please kindly note that your support ticket will be free if it is Microsoft's issue.
    Thanks for your understanding.


    Best Regards,
    Amy Peng

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, December 18, 2015 8:03 AM
  • There is indeed an issue. Have a look at this thread:

    https://social.msdn.microsoft.com/Forums/Windowsapps/en-US/a80d890f-d0ec-42bf-98b3-baf41893530f/previouslypurchased-durable-iaps-not-being-recognized?forum=wpsubmit&prof=required

    It looks like that many UWP apps that have been updated (since) last Friday have problems with the IAPs. My app Action Note has the same problem as well. Since the last update, no IAP is working anymore. IsProductActive["..."] is throwing an Exception for example, as well as even after a new purchase of the product, the IAP is not working after restarting the app!

    Monday, December 21, 2015 5:38 PM