none
Regional settings and decimal separator RRS feed

  • Question

  • I use Excel 2010 vba code to read .txt files and make some calculations afterwards.

    The problem I have faced is that once, I have changed regional settings from Danish to UK, numbers that are imported to Excel sheet became Integer... No separator at all...

    This is how line of numbers looks like in text file:

    2015-09-28 11:20:30;174,4165;8;17,94556;17,94556;61,86356;29,52779;4974;1240,5;

    The same number should appear on Excel sheet disregard the regional settings.

    Does anybody know, how can I fix that problem?

    Thank you!

    Monday, October 5, 2015 8:43 AM

Answers

  • Hi GyTasS,

    Excel use the system separator by default. If you want Excel to use your own separator you can change the option like below:(refer to Change the character used to separate thousands or decimals)

    1. Click the Microsoft Office Button Office button image, and then click Excel Options.

    • 2. On the Advanced tab, under Editing options, clear the Use system separators check box.

    • 3. Type new separators in the Decimal separator and Thousands separator boxes.

      <include item="tip">Tip </include>  When you want to use the system separators again, select the Use system separators check box.

    Hope it is helpful.

    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, October 6, 2015 2:27 AM
    Moderator