locked
Emailing report with group expanded RRS feed

  • Question

  • I have this report in SSRS2008. it has a group. Users that subscribe to receive this report by email get the report with the group not expanded.

    How do I email the report with all the detail rows expanded?

    Thanks,

    Friday, January 7, 2011 6:23 PM

Answers

  • See if this helps

    http://msdn.microsoft.com/en-us/library/ms159830.aspx

     


    Mike Davis, MCTS, MCITP
    • Marked as answer by Jerry Nee Monday, January 24, 2011 9:05 AM
    Monday, January 10, 2011 3:07 PM
  • Hi n2201,

    The solution Mike provided should be able to statify your requirement. Here are the main steps for your reference:

    1. Define a report parameter called Para1 with Integer data type, and set its default value to 1.

    2. Assuming the Textbox called Group1 to toggle the groups, click it and go to its Properties pane, set its InitialToggleState to =IIF(Parameters!Para1.Value=1,False,True)

    3. Open the group detail Properties dialogue box, and set its visibility to =IIF(Parameters!Para1.Value=1,True,false)

    preview the report for test. Then, change the report parameter visiblity to Internal type. When you setup the subscription on this report, you can set the parameter para1 to 0 as its default value.

    thanks,
    Jerry

    • Marked as answer by Jerry Nee Monday, January 24, 2011 9:05 AM
    Monday, January 17, 2011 7:10 AM

All replies

  • You will have to have the group expanded by default in the report. You can set a parameter to control the group details visibility. In the subscription set this parameter to show the details.
    Mike Davis, MCTS, MCITP
    • Proposed as answer by Jerry Nee Monday, January 10, 2011 5:19 AM
    Friday, January 7, 2011 6:48 PM
  • Thanks Mike for the reply. I tried multiple ways of setting the parameter to True and False, in Tablix properties and Row Visibility. I have not been succesful.

    Could you tell me where and how to set the parameter?

    Thanks

    Monday, January 10, 2011 1:30 PM
  • When you set the group to hide you set it to toggle based on an item. Click on the fx box next to the toggle item and enter the parameter you created.
    Mike Davis, MCTS, MCITP
    Monday, January 10, 2011 1:33 PM
  • I am using SSRS 2008, I tried that but it did not work :(

    Monday, January 10, 2011 3:02 PM
  • See if this helps

    http://msdn.microsoft.com/en-us/library/ms159830.aspx


    Mike Davis, MCTS, MCITP
    Monday, January 10, 2011 3:06 PM
  • See if this helps

    http://msdn.microsoft.com/en-us/library/ms159830.aspx

     


    Mike Davis, MCTS, MCITP
    • Marked as answer by Jerry Nee Monday, January 24, 2011 9:05 AM
    Monday, January 10, 2011 3:07 PM
  • Thank Mike, I  appreciate you helping me.

    I did as mentioned in the article. The result is same, that is, the rows in the group are not visible on opening the report, user has to click on the + sign next to the group to expand the detailed rows.

    This results in the emailed report goes as group summary with no details. As of now I see no other option but to remove the group :( That is not a great option because I loose group totals.

    Tuesday, January 11, 2011 4:53 AM
  • Hi n2201,

    The solution Mike provided should be able to statify your requirement. Here are the main steps for your reference:

    1. Define a report parameter called Para1 with Integer data type, and set its default value to 1.

    2. Assuming the Textbox called Group1 to toggle the groups, click it and go to its Properties pane, set its InitialToggleState to =IIF(Parameters!Para1.Value=1,False,True)

    3. Open the group detail Properties dialogue box, and set its visibility to =IIF(Parameters!Para1.Value=1,True,false)

    preview the report for test. Then, change the report parameter visiblity to Internal type. When you setup the subscription on this report, you can set the parameter para1 to 0 as its default value.

    thanks,
    Jerry

    • Marked as answer by Jerry Nee Monday, January 24, 2011 9:05 AM
    Monday, January 17, 2011 7:10 AM