locked
Get app pool to run php under Administrator user in IIS6 RRS feed

  • Question

  • User1368048027 posted

    I hope someone can help here. Please note I am not a server admin but my current hosting company can't seem to solve the issue. I have root access and can get around the server, but am in no way an expert.

    Our server runs on the HSphere control panel by Parallels. There is some issue with one of their dll's that repeatedly crashes w3wp.exe and therefore causes all app pools to recycle. For our .NET and standard html sites, we changed the app pools to run under Administrator instead of NETWORK SERVICE and the HSphere w3wp.exe stopped crashing, so we are going to leave them under admin temporarily until Parallels can fix the issue (they are pretty slow).

    However, when we switch our php app pools to run under administrator, we get

    Your are not authorized to view this page. 
    HTTP Error 403 - Forbidden: Access is denied.

    Does anyone know how I can make the php work under the Administrator account? This is Win 2k3 with IIS6.

    Saturday, May 4, 2013 12:48 PM

All replies

  • User1124521738 posted

    are you using a 5.2 isapi or a 5.3/5.4 cgi php installation?

    Saturday, May 4, 2013 1:50 PM
  • User1368048027 posted

    It would be whatever HSphere installs by default. I believe it is the CGI. When I do a php get info from a current site, under server api, it has: CGI/FastCGI. 

    This is what's under the system output (not sure if this is of any value): Windows NT STABILIT-F01E82 5.2 build 3790

    Also, we don't have any ISAPI filters set on the site.

    If you need any more information, or have any ideas, please let me know.

    Saturday, May 4, 2013 2:00 PM
  • User1124521738 posted

    unfortunately, no real ideas here specific to this config, even though I have been on virtuozzo containers for many years (also by Parallels), I've always installed php from the downloadable zips and on Win2k3 I only ever had luck getting php to work using the ISAPI dll rather than installing as a fast cgi, only when I got to 2008R2 was I able to get the CGI mode to install.

    I will throw this out - you've changed the security user of the app pool, and granted it's to the admin, who should have permission to access everything, but double the permissions of the webroots for your sites, it could be something as silly as only the IUSR accounts (or the other IIS related accounts) having access, also double check that IIS has anon access enabled (of course this assumes that the site is for the general public).

    Saturday, May 4, 2013 2:28 PM
  • User1368048027 posted

    Thanks for your input. I checked and IIS does have anonymous access enabled.

    I did find that if I set the app pool to run under Local System then the sites run fine. To me, this would be in heavy favor of a permissions issue. However, I don't know what permissions I would need to check or set. I have read that running under Local System is very bad for public facing websites, however, Paralells should be able to resolve this within a few days, would it be safe to run under Local System for a few days?

    Again, thanks for your input.

    Saturday, May 4, 2013 3:15 PM