locked
Outgoing emails have new From Address RRS feed

  • Question

  • I have a SPD2007 workflow that has been working since early 2008. The workflow sends a string of information to another system which then reacts based on the string. The issue we are having is that the From address (noted in the header from a working email as of 1/18/2011) is limited to the item we placed in the Application outgoing settings (CirrusWeb@cirrus.com).

    Working before:

    Date: 24 Sep 2010 08:55:24 -0500

    From: <CirrusWeb@cirrus.com>

    To: <bugzilla@cvsrep.cirrus.com>

    Content-Transfer-Encoding: 8bit

    Content-Type: text/html; charset=utf-8

    Subject: [Bug 91681]

    MIME-Version: 1.0

    X-Mailer: Windows SharePoint Services (version 3)

    Message-ID: <AUSMSG-02dLFKG3YYws00000b32@CLMSG-01.ad.cirrus.com>

    X-OriginalArrivalTime: 24 Sep 2010 13:55:24.0504 (UTC) FILETIME=[22D7D580:01CB5BF0]

    Now, the emails, as of 1/21/2011 include the site name in the header, but as a GUID. See the test below. I have gone back and verified that ALL emails sent from whatever web application have the deafualt application email (someweb@cirrus.com) as well as the site/subsite name included.

    Not working now:

    Date: Tue, 8 Feb 2011 09:27:27 -0600

    To: <bugzilla@cvsrep.cirrus.com>

    Content-Transfer-Encoding: 8bit

    From: =?utf-8?B?RGlzdHJpYnV0aW9uIExpY2Vuc2UgVHJhY2tpbmc=?=

            <CirrusWeb@cirrus.com>

    Content-Type: text/html; charset="utf-8"

    Subject: [Bug 91605]

    MIME-Version: 1.0

    X-Mailer: Windows SharePoint Services (version 3)

    Message-ID: <5dcd0505-cc76-4ef9-aee7-ad6404e262fd@EX4.ad.cirrus.com>

    This apparently changed when we installed Exchange 2010 and SharePoint updates on 1/19/2011. The problem is I need to turn off the site name or have the site name actually be used instead of the GUID. When did this change (what update and is it modifiable?)?


    Greg McAllister
    Tuesday, February 8, 2011 7:03 PM