none
Hidden fields on the Split form RRS feed

  • Question

  • So I have created a Split Form. I have also set Visible=No for certain fields so they do not appear on the form.

    However they are still showing up on the datasheet portion of the form.  Is there any way to stop this happening?

    I have tried it on Access 2010 and Access 2016.

    Wednesday, February 17, 2016 6:58 AM

Answers

  • With your form open (not in design view), right-click on the column header of the field in question, and select "Hide Fields".

    Miriam Bizup Access MVP

    • Marked as answer by serenejen Wednesday, February 17, 2016 1:46 PM
    Wednesday, February 17, 2016 10:07 AM

All replies

  • With your form open (not in design view), right-click on the column header of the field in question, and select "Hide Fields".

    Miriam Bizup Access MVP

    • Marked as answer by serenejen Wednesday, February 17, 2016 1:46 PM
    Wednesday, February 17, 2016 10:07 AM
  • Well what do you know - that works. Thanks.

    Now can that be done programmatically?

    Wednesday, February 17, 2016 1:46 PM
  • I've tried that programmatically... with ZERO luck. I have played with split forms out of curiosity when that feature first came out, but For my own projects, I avoid the built in Split Form option, but rather develop my own main forms with subforms in datasheet view. I find that approach gives you much greater flexibility both in terms of layout and programming option.  If you are unfamiliar with using subforms, take a look at this tutorial:

    Subform tutorial


    Miriam Bizup Access MVP

    Wednesday, February 17, 2016 4:26 PM