locked
Shared SSL problem RRS feed

  • Question

  • User-101954315 posted

     SSL is setup on host server. (Shared SSL with <LABEL for=fid-name>Virtual directory name</LABEL> if that matters). Works fine when I access html files http:\\sercurehostserver.com\mydir\myfile.html

    But when I try to access a asp.net file http:\\sercurehostserver.com\mydir\myfile.aspx I get...

    500 - Internal server error.

    There is a problem with the resource you are looking for, and it cannot be displayed

    It knows the file is there because when I misspell it on purpose, i get a different error.  Why won't it display the file?

    Thanks in advance.

    Sunday, June 13, 2010 10:44 PM

Answers

  • User915387828 posted

    Hi sicardg,

    Please disable "Show Friendly HTTP error messages" of IE and enable "detailed errors for remote clients" in your ASP.NET application. After running the application please observe what errors are being thrown.

    To turn off ASP.NET custom errors, place the following in your  web.config:
    <system.web>
       <customErrors mode=”Off”  />
    </system.web>

    And please use Event Viewer.  This will show you the error which IIS reports. The second thing that I would do is to look at the IIS Log files.  

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, June 17, 2010 2:14 AM