locked
VS 2010 local reports RRS feed

  • Question

  • Hi,

    I have an .aspx page which contains a report viewer control. It loads a stacked column chart(local report). It will have some group name in x-axis and respective count in y-axis. But when the count is 0, it is giving some black colored arrows.

    I want to remove those arrows. when i searched for it i get answers for ssrs. But I am using VS 2010 local reports.

    Can somebody help me to solve this issue?

    Thanks,

    Farjana

    Tuesday, November 19, 2013 5:24 AM

Answers

  • Hi Farjana,

    Thank you for your reply.

    Did you want to disable the black arrow no matter in any situation? Please refer to the following steps:
    1. Click the Data Label in the chart. Expand the “SmartLabels” Property in the Properties dialog box.
    2. Click the arrow below “CalloutLineColor” property. Select “More colors” option.
    3. In the Select Color dialog box, select White color, and modify the Alpha’s value to 0.

    Please refer to the screenshot below:

    If you have any questions, please feel free to ask.

    Regards,
    Alisa Tang


    Alisa Tang
    TechNet Community Support

    • Marked as answer by Farjana Thursday, November 21, 2013 5:11 AM
    Thursday, November 21, 2013 1:53 AM

All replies

  • Hi Farjana,

    Based on your description, I created a similar report in my test environment. I can reproduce the same issue as your post.

    When we configure the “Show Data Labels” in the chart, we get the count is 0, we will get a black arrow in the chart. In your case, we can use expression in the chart to work around the issue. Suppose we have two fields named Count1 and Count2. Please refer to the steps below:
    1. Right click the Count1’s Data Label in the chart. Select “Series Label Properties”.
    2. Click the expression icon below “Label data” type below expression:
    =IIF(Count(Fields!Count1.Value)=0 ,Nothing,Count(Fields!Count1.Value))
    3. Use the same method to configure Count2’s Data Label.

    You can refer the screenshot below:
     
    If you have any questions, please feel free to ask.

    Regards,
    Alisa Tang


    Alisa Tang
    TechNet Community Support

    Wednesday, November 20, 2013 8:24 AM
  • Hi Alisa,

    Thanks for your reply. Actually when the count is zero, i want that count to be displayed as "0" but without the arrow mark. I tried your expression, but in the attached image you can see, either when there are continuous two zero counts (or) when the count of the second bar is very less and followed by zero, the arrow is coming. If you see the "Daimler" one, even if there is a zero count, no arrow is coming because the second bar is considerably long. "I feel that the report is creating the arrows to differentiate between the bars when the bar size is very small"

    

    Wednesday, November 20, 2013 10:21 AM
  • Hi Farjana,

    Thank you for your reply.

    Did you want to disable the black arrow no matter in any situation? Please refer to the following steps:
    1. Click the Data Label in the chart. Expand the “SmartLabels” Property in the Properties dialog box.
    2. Click the arrow below “CalloutLineColor” property. Select “More colors” option.
    3. In the Select Color dialog box, select White color, and modify the Alpha’s value to 0.

    Please refer to the screenshot below:

    If you have any questions, please feel free to ask.

    Regards,
    Alisa Tang


    Alisa Tang
    TechNet Community Support

    • Marked as answer by Farjana Thursday, November 21, 2013 5:11 AM
    Thursday, November 21, 2013 1:53 AM
  • Hi Alisa,

    Thanks. It worked properly.

    Another request: when i export a report, i can save it to local machine. I want to set the author attribute for the downloaded report. In Report properties, there is an attribute called "Author", but it didn't work out. Can you tell me how i can set the author property for the report or reportviewer, so when i download, it will have the author as given name

    Thanks,

    Farjana

    Thursday, November 21, 2013 5:15 AM