locked
.Net framework 4.5.1 does not shown in the vs 2012 RRS feed

  • Question

  • User1720628292 posted

    I wanted to upgrade from .net 4.5 to 4.5.1. I installed it successfully(Windows 7).But i could not find it in the vs 2012 express for web.It shows .net 4 and 4.5.

    I got this error

    The microsoft.Visualstudio.Editor.Implementation.Editot package did not load correctly.The problem may be caused by configuration change or by installation of another extension

    Friday, May 2, 2014 2:26 AM

Answers

  • User724169276 posted

    Hello Ram,

    The framework which you are trying to work on is not meeting the minimum requirements of your system.Before installing any framework you should check the requirements also.The requirements for .NET Framework 4.5.1 are :

    Supported Operating System

    Windows 7 Service Pack 1, Windows 8, Windows Server 2008 R2 SP1, Windows Server 2008 Service Pack 2, Windows Server 2012, Windows Vista Service Pack 2

    Hardware Requirements:

      • 1 GHz or faster processor
      • 512 MB of RAM
      • 850 MB of available hard disk space (x86)
      • 2 GB of available hard disk space (x64)

    Upgrade your windows 7 to windows 7 service pack 1

    Source Here.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, May 2, 2014 5:37 AM
  • User-1454326058 posted

    Hi RamThilak,

    About how to install windows 7 service pack 1, please refer to:

    # Learn how to install Windows 7 Service Pack 1 (SP1)

    http://windows.microsoft.com/en-in/windows7/install-windows-7-service-pack-1

    On the other hand, there is a link that may benefit you:

    # .NET Framework SDKs and Downloads

    http://blogs.msdn.com/b/dotnet/p/dotnet_sdks.aspx#

    Thanks

    Best Regards

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, May 5, 2014 2:56 AM

All replies

  • User-358979764 posted

    Hi Ram,

    You need to install VS 2013 Express.

    VS 2012 >> .NET 4.5

    VS 2013 >> .NET 4.5.1

    Friday, May 2, 2014 3:06 AM
  • User1720628292 posted

    Hi,

    I could not change the os from windows 7 to windows 8 for visual studio 2013.The following link tells it is possible to work with vs 2012 for 4.5.1

    http://samirvaidya.blogspot.in/2013/11/developing-with-net-framework-451-using.html

    But it has the download link that requires windows 7 service pack1 .I'm having just windows 7 only.

    http://www.microsoft.com/en-us/download/details.aspx?id=40772

    How could i install that?Anyother alternative soltion

    Friday, May 2, 2014 3:18 AM
  • User724169276 posted

    Hello Ram,

    The framework which you are trying to work on is not meeting the minimum requirements of your system.Before installing any framework you should check the requirements also.The requirements for .NET Framework 4.5.1 are :

    Supported Operating System

    Windows 7 Service Pack 1, Windows 8, Windows Server 2008 R2 SP1, Windows Server 2008 Service Pack 2, Windows Server 2012, Windows Vista Service Pack 2

    Hardware Requirements:

      • 1 GHz or faster processor
      • 512 MB of RAM
      • 850 MB of available hard disk space (x86)
      • 2 GB of available hard disk space (x64)

    Upgrade your windows 7 to windows 7 service pack 1

    Source Here.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, May 2, 2014 5:37 AM
  • User-1454326058 posted

    Hi RamThilak,

    About how to install windows 7 service pack 1, please refer to:

    # Learn how to install Windows 7 Service Pack 1 (SP1)

    http://windows.microsoft.com/en-in/windows7/install-windows-7-service-pack-1

    On the other hand, there is a link that may benefit you:

    # .NET Framework SDKs and Downloads

    http://blogs.msdn.com/b/dotnet/p/dotnet_sdks.aspx#

    Thanks

    Best Regards

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, May 5, 2014 2:56 AM