none
Set-SPEnterpriseSearchTopology : Could not connect to the HostController service on ServerName

    Question

  • Hello,

    I have SP2013 farm: 2 WFEs with Query Processing components and 2 servers with all other components.

    For some reason on the 1st WFE Query Processing component became corrupted.

    Status for this component:

    Name    : QueryProcessingComponent1
    State   : Degraded
    Level   :
    Message : Non-active: Microsoft.Ceres.SearchCore.Query.MarsLookupComponent.MarsLookupComponent: Resolving,
              QueryProcessingComponent1.RemoteSharepointComponent: Resolving, QueryProcessingComponent1.ImsQueryInternalComponent: Resolving,
              QueryProcessingComponent1.QueryPipelineComponent: Resolving, QueryProcessingComponent1.InteractionEngineComponent: Resolving
    Details : {[Host, WFE1]}

    I tried to run:

    Start-SPEnterpriseSearchQueryAndSiteSettingsServiceInstance -Identity "SERVERNAME"

    This did not resolve the issue.

    Tried to restart server - did not help.

    Tried to make clone of current topology, removed affected component and recreated it. When I try to activate clone topology using command:

    Set-SPEnterpriseSearchTopology -identity $clone

    I get error:

    Set-SPEnterpriseSearchTopology : Topology activation failed. Could not connect to HostController on server WFE1
    At line:1 char:1
    + Set-SPEnterpriseSearchTopology -identity $clone
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidData: (Microsoft.Offic...tSearchTopology:SetSearchTopology) [Set-SPEnterpriseSearchTopology], SearchTopologyAct
       ivationException
        + FullyQualifiedErrorId : Microsoft.Office.Server.Search.Cmdlet.SetSearchTopology

    That's what I found in ULS logs:

    Microsoft.Office.Server.Search.Administration.Topology.SearchTopologyActivationException: Topology activation failed. Could not connect to HostController on server WFE1  at Microsoft.Office.Server.Search.Administration.Topology.SearchTopology.ActivateSilently()     at Microsoft.Office.Server.Search.Administration.Topology.SearchTopology.Activate()     at Microsoft.SharePoint.PowerShell.SPCmdlet.ProcessRecord()    
    Error Category: InvalidData    Target Object  Microsoft.Office.Server.Search.Cmdlet.SetSearchTopology  Details  NULL  RecommendedAction NULL  

    In the ProcessMonitor I see that hostcontrollerservice.exe and NodeRunner.exe are working.

    Firewall on the affected server is disabled.

    Tuesday, December 22, 2015 10:16 AM

Answers

All replies