none
VS 2015 Community : Symbol Loading makes my computer freeze badly

    Question

  • It's pretty much all in the title.

    Upon loading symbols the first time I run my app in debug mode (sometimes randomly after a few runs), the symbol loading stops on a random dll and completely freezes my PC to the point I need to hard shutdown it and reboot.

    What am I supposed to do ? I don't want to disable symbols loading, I need to set breakpoints from time to time.

    Maybe I should mention that ctrl-al-del has no effect.

    Note on symbols : I'm loading all symbols from Microsoft servers.

    Thanks for your answer.


    Saturday, November 14, 2015 11:06 PM

Answers

  • Hi HarassmentStudio,

    >>I'm loading all symbols from Microsoft servers.

    I think this may cause the freezes problem. Since when I select "Microsoft Symbol Servers" option in Symbol file (.pdb) locations, I get following warning message. I suggest you select "Only specified modules" option in "Automatically load symbols for", which can improve the debugging performance as the message metioned.

    The performance of remote symbol stores can vary due to latency, bandwidth, or availability of servers.  Debugging performance can be improved by selecting the option to load only specified modules when enabling this server.

    In addition, please try assign a cache directory in menu Tools -> Options -> Debugging -> Symbols to cache symbols, which needn't to load Symbol file every time when you debugging.

    Best Regards,
    Weiwei

    Tuesday, November 17, 2015 2:22 AM
    Moderator

All replies

  • Hi HarassmentStudio,

    >>I'm loading all symbols from Microsoft servers.

    I think this may cause the freezes problem. Since when I select "Microsoft Symbol Servers" option in Symbol file (.pdb) locations, I get following warning message. I suggest you select "Only specified modules" option in "Automatically load symbols for", which can improve the debugging performance as the message metioned.

    The performance of remote symbol stores can vary due to latency, bandwidth, or availability of servers.  Debugging performance can be improved by selecting the option to load only specified modules when enabling this server.

    In addition, please try assign a cache directory in menu Tools -> Options -> Debugging -> Symbols to cache symbols, which needn't to load Symbol file every time when you debugging.

    Best Regards,
    Weiwei

    Tuesday, November 17, 2015 2:22 AM
    Moderator
  • This answer is wrong. When the poster first debugged his program any symbol files would have downloaded into the cache. When he re-ran the program again, the symbol servers would not be accessed as the files were already in the cache. There is a deeper problem occurring here.

    I'm seeing this problem now with community 2015.  I debug my app once, maybe twice and it is fine. Then the next time, it hangs claiming to be loading symbols for module mumble_foo.

    It puts up a dialog that appears to give the opportunity to cancel the symbol load, but it is too late; 'not responding' shows up as soon as you click something and then you're hosed.

    You cannot start the task manager.

    You cannot even use Ctrl-Alt_Del.

    This is a LOT more serious than a slow server. 

    DO NOT ANSWER QUESTIONS WITH GUESSES AND SUPPOSITIONS.

    This problem is wasting a lot of my time looking for an answer.  It ANGERS me that I come to Microsoft looking for a solution and find a GARBAGE reply of the sort above.


    • Edited by Chozo_99 Wednesday, August 17, 2016 4:01 PM
    Wednesday, August 17, 2016 3:59 PM
  • I get this with 2013.  When I run my program it takes ages to start, if at all.  I'm sure something's up with the symbol server.  I turned off load all anyway.  I'm loading them on demand from the modules window now.

    If you want to know about symbol hell, just try to use WPA :).

    • Edited by RobinsonUK Tuesday, September 06, 2016 10:18 PM
    Tuesday, September 06, 2016 10:18 PM