locked
java.lang.IllegalArgumentException: already added : Lcom/google/android/gms/internal/zzpz RRS feed

  • Question

  • User237580 posted

    I have a problem when compiling the project Error* java.lang.IllegalArgumentException: already added : Lcom/google/android/gms/internal/zzat;* Any idea how to solve?

    Sunday, August 6, 2017 5:29 AM

All replies

  • User351937 posted

    Any idea how to solve?

    Wednesday, October 4, 2017 3:13 PM
  • User363134 posted

    I solved it by removing Xamarin.Android.Support.v4

    Friday, January 19, 2018 7:53 AM
  • User163681 posted

    @AjaysinhDodiya said: I solved it by removing Xamarin.Android.Support.v4

    I Am using OneSignal that is depending on Xamarin.Android.Support.v4, hence I can't remove it Any other solution ?

    Saturday, January 20, 2018 11:04 PM
  • User364425 posted

    I am assuming OneSignal is a Nuget package, if it is a Nuget package, I recommend that you remove it. Then, I recommend that you remove "Xamarin.Android.Support.v4" and then try reinstalling "OneSignal" and "Xamarin.Android.Support.v4", ensuring you are running the latest NuGet packages.

    Sunday, January 21, 2018 10:46 PM
  • User163681 posted

    I delete all dependencies for Xamarin.Android.Support.v4 and I reinstalled the Nuget Packages and still having the same problem,

    I am trying for like a week , but nothing is working for me.

    Can anyone help ?

    Sunday, January 28, 2018 1:29 AM
  • User364425 posted

    Did you try removing packages starting with Xamarin.GooglePlayServices.* and reinstalling it again?

    Sunday, January 28, 2018 11:59 PM
  • User163681 posted

    I deleting All packes depending on Xamarin.Android.Support.v4 Even Xamarin.forms, and I reinstalled everything again

    But Still the same problem

    I tried this on my Mac Machine and in my Windows machine

    Nothing is working

    Monday, January 29, 2018 2:26 PM
  • User237580 posted

    All you Google service plug-in should be of the same version, try uninstalling and re-installing your packages, delete you bin and obj folders. Try again.

    Monday, January 29, 2018 4:07 PM
  • User163681 posted

    @DharumaRaj said: All you Google service plug-in should be of the same version, try uninstalling and re-installing your packages, delete you bin and obj folders. Try again.

    You saved my time,

    This worked great, This what has happening for people will face the same issue,

    I installed Onesignal that depends on Xamarin.googleplayservices.Gcm, and it installed the minimum version required.

    Then I installed the Xamarin.googleplayservices.Ads and It instelled latest dependencies and the .Gcm was there already (with older version) this made the inappropriate package version.

    After making all Google play services having the same version , it worked Great,

    Thank you so much,

    Monday, January 29, 2018 5:43 PM
  • User368627 posted

    @DharumaRaj said: All you Google service plug-in should be of the same version, try uninstalling and re-installing your packages, delete you bin and obj folders. Try again.

    Excelente amigo! a mi también me funcionó. Llevaba varios días sufriendo. Muchas gracias.

    Wednesday, May 16, 2018 5:52 AM
  • User350049 posted

    Please can any one help all Google service plug-in same version but this doesn't help me .

    Sunday, June 3, 2018 11:57 AM
  • User371160 posted

    @herzdevelop said:

    @DharumaRaj said: All you Google service plug-in should be of the same version, try uninstalling and re-installing your packages, delete you bin and obj folders. Try again.

    Excelente amigo! a mi también me funcionó. Llevaba varios días sufriendo. Muchas gracias.

    Great!!! you save my life!!! thank you!!!

    Thursday, September 27, 2018 2:38 PM