locked
ssrs report not displaying report parameters RRS feed

  • Question

  • Until recently an ssrs 2008 report,  displayed all the report parameters for the users to select how the reports execute.
    Now the report parameters do not display. The reports execute with the automatic values. The ssrs reports have not changed within the last year. Both the test and production report servers have the latest updates. I am not certain about the sql server updates for sql server 2008 and sql server 2012. Thus can you tell me what you think I should look at?

    Would the report server need some kind of an upgrade and/or possibly the ssrs reports? If so, what version would the report server need to be? Can you suggest what I should look at?


    Friday, December 4, 2015 9:37 PM

Answers

  • Hi wendy,

    According to your description, your report have the entire parameter pane hidden and execute with default values. Right?

    Firstly, I suggest you open the .rdl in Report Builder or BIDS. Make sure those report parameters are not hidden. Check if the parameter displayed preview. If it works properly, please check if there's any embedded code on page file to hide the parameter pane.

    Native mode:

    C:\Program Files\Microsoft SQL Server\MSRS12.MSSQLSERVER\Reporting Services\ReportManager\Pages\Report.aspx

    SharePoint integrated mode:

    C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\TEMPLATE\LAYOUTS\ReportServer\RSViewer.aspx

    Also it has similar issue in SSRS R2+ SharePoint 2010 environment, it seems the issue is fixed in SSRS 2012. Please see a feedback below:

    https://connect.microsoft.com/SQLServer/feedback/details/721979/parameters-disappear-when-report-is-rendered-with-parameters-drawer-collapsed

    Regards,


    Simon Hou
    TechNet Community Support


    Monday, December 7, 2015 12:28 PM
  • Hello

    The Report Parameters cannot just simply "disappear"; either there has been a change to SSRS, or the operating System where the RS site is set up, or someone has made a change to the the RDL and republished it (note that a Content Manager can download the RDL direct from the RS Site; make changes and then redeploy it).

    Try running the Report from another PC to see if the Parametes "reappear"

    If you have control of the correct RDL; check it out in Visual Studio to see if it is working as intended and then deploy it again

    Is this happening with just one Report or several Reports?  If it's happening with any Report that has Parameters then see if there have been any changes; a change to SQL Server will have required a SQL Server restart.


    Please click "Mark As Answer" if my post helped. Tony C.

    Monday, December 7, 2015 1:07 PM

All replies

  • Hi wendy,

    According to your description, your report have the entire parameter pane hidden and execute with default values. Right?

    Firstly, I suggest you open the .rdl in Report Builder or BIDS. Make sure those report parameters are not hidden. Check if the parameter displayed preview. If it works properly, please check if there's any embedded code on page file to hide the parameter pane.

    Native mode:

    C:\Program Files\Microsoft SQL Server\MSRS12.MSSQLSERVER\Reporting Services\ReportManager\Pages\Report.aspx

    SharePoint integrated mode:

    C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\TEMPLATE\LAYOUTS\ReportServer\RSViewer.aspx

    Also it has similar issue in SSRS R2+ SharePoint 2010 environment, it seems the issue is fixed in SSRS 2012. Please see a feedback below:

    https://connect.microsoft.com/SQLServer/feedback/details/721979/parameters-disappear-when-report-is-rendered-with-parameters-drawer-collapsed

    Regards,


    Simon Hou
    TechNet Community Support


    Monday, December 7, 2015 12:28 PM
  • Hello

    The Report Parameters cannot just simply "disappear"; either there has been a change to SSRS, or the operating System where the RS site is set up, or someone has made a change to the the RDL and republished it (note that a Content Manager can download the RDL direct from the RS Site; make changes and then redeploy it).

    Try running the Report from another PC to see if the Parametes "reappear"

    If you have control of the correct RDL; check it out in Visual Studio to see if it is working as intended and then deploy it again

    Is this happening with just one Report or several Reports?  If it's happening with any Report that has Parameters then see if there have been any changes; a change to SQL Server will have required a SQL Server restart.


    Please click "Mark As Answer" if my post helped. Tony C.

    Monday, December 7, 2015 1:07 PM
  • Some people are saying what Wendy describes is impossible.   In June 2020 with VS 2015 enterprise it happened to me.   I had a working report.   I added some complex logic that introduced a dynamic where clause.   ssrs accepted the code but at some stage the parameters dissapeared (when you ran the report there were no pull downs for the two parameters I was selecting on).   To get the parameters back at run time I stripped the report back to simple where column_name = @ssrsParameter and the pick lists still wouldn't come back at run time.  Update and possible help to others.   I closed the ssrs project and went away overnight.   Came back in the next morning and did a rebuild, clean, build and the parameters came back.
    • Edited by etlman Wednesday, June 10, 2020 3:30 PM
    Wednesday, June 10, 2020 3:19 PM