locked
.ipa file not linked with Calabash RRS feed

  • Question

  • User1996 posted

    Hello

    I've written my xamarin.uitests and successfully excuted them locally for both Android and iOS platforms. However although the Android tests work in the Xamarin Test Cloud I am experiencing an issue with the iOS execution. I recieve the message

    'The .ipa file does not seem to be linked with Calabash framework'

    I've looked through the documentation but I can't find anything relating to this error. Does anyone have any suggestions on solving this problem?

    Thanks

    MITL

    Tuesday, January 19, 2016 11:22 AM

Answers

  • User1996 posted

    Solved it. I had a semi colon in the complier directive so instead of

    DEBUG;ENABLETESTCLOUD;

    I had

    DEBUG:ENABLETESTCLOUD;

    Consequently

    if ENABLETESTCLOUD Xamarin.Calabash.Start(); endif

    was never executed. Simple in the end!

    MITL

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Wednesday, January 20, 2016 10:08 AM

All replies

  • User1996 posted

    Solved it. I had a semi colon in the complier directive so instead of

    DEBUG;ENABLETESTCLOUD;

    I had

    DEBUG:ENABLETESTCLOUD;

    Consequently

    if ENABLETESTCLOUD Xamarin.Calabash.Start(); endif

    was never executed. Simple in the end!

    MITL

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Wednesday, January 20, 2016 10:08 AM
  • User185434 posted

    Hello Man In The Loft,

    I have exactly the same problem as you .

    Please, Can you describe, step by step, the resolution of this problem ?

    Thank you, Anthony M.

    Wednesday, January 20, 2016 3:38 PM
  • User1996 posted

    @AnthonyMehallel - I've PM'd you a rough guide. Let me know how it goes.

    MITL

    Thursday, January 21, 2016 8:37 AM
  • User185434 posted

    @ManInTheLoft , Yes Thanks ! I just answer in MP.

    Anthony M.

    Thursday, January 21, 2016 9:19 AM
  • User193789 posted

    @ManInTheLoft can you please post the resolution here as well

    Thursday, May 5, 2016 11:45 PM
  • User163022 posted

    This was my problem:

    Navigate to YOUR_SOLUTION -> Options -> Compiller and select the debug configuration. Set the device as iPhone.

    Now you should see ENABLETESTCLOUD as a Debug directive, if its not there then add it or else the code:

    if ENABLETESTCLOUD Xamarin.Calabash.Start(); endif

    wil not execute at all causing that error to be thrown.

    Make sure to add it with a semi colon.

    Thursday, June 23, 2016 12:23 PM
  • User240190 posted

    @ManInTheLoft
    can you please post the resolution here as well

    Saturday, July 9, 2016 1:12 AM
  • User278370 posted

    In xamarin test cloud, my error went, when I put my ios file to debug|iphone, compile whole solution, I removed .AppBundle step from BeforeEachTest() step as my UITest project is part of solution, and I added ios project in Unit test window (I am using Xamarin studio on Mac machine). then I submitted test after compilation to run on Xamarin test cloud.

    I was also needed to put this variable in compiler attribute in debug configuration, thanks! >>

    " @ManInTheLoft said: Solved it. I had a semi colon in the complier directive so instead of

    » show previous quotes I had

    » show previous quotes Consequently

    » show previous quotes was never executed. Simple in the end!

    MITL"

    Friday, November 25, 2016 11:10 AM
  • User278370 posted

    @ManInTheLoft said: Solved it. I had a semi colon in the complier directive so instead of

    DEBUG;ENABLETESTCLOUD;

    I had

    DEBUG:ENABLETESTCLOUD;

    Consequently

    if ENABLETESTCLOUD Xamarin.Calabash.Start(); endif

    was never executed. Simple in the end!

    MITL

    I was also needed to put this variable in compiler attribute in debug configuration, thanks!

    Friday, November 25, 2016 11:11 AM
  • User269861 posted

    @ChristoNel said: This was my problem:

    Navigate to YOUR_SOLUTION -> Options -> Compiller and select the debug configuration. Set the device as iPhone.

    Now you should see ENABLETESTCLOUD as a Debug directive, if its not there then add it or else the code:

    if ENABLETESTCLOUD Xamarin.Calabash.Start(); endif

    wil not execute at all causing that error to be thrown.

    Make sure to add it with a semi colon.

    I dont see ENABLETESTCLOUD option in my compiler. How can i get that?

    Tuesday, June 6, 2017 3:58 PM
  • User1996 posted

    @Subby

    Navigate and select the project (not solution) -> right click and select options -> select compiler -> in the section 'Define Symbols' ensure the entry 'ENABLETESTCLOUD;' is present. You'll probably also have 'DEBUG;'. Don't forget the semicolons ';'. You have to physically type these values in the section.

    MITL

    Tuesday, June 6, 2017 4:58 PM
  • User163022 posted

    @Subby

    Once your on the "Compiller" tab inside the Options window, make sure your configuration is set to Debug. You should see a label saying "Define Symbols:" inside this window with a TextField next to it.

    If you don't have the "ENABLETESTCLOUD" symbol there just add it and remember the semi-colons.

    Here is a screenshot for you of what mine looks like:

    Wednesday, June 7, 2017 6:10 AM